Internal Error in StartAppShare

Hi,

I am unable to get sharing working. I am using custom UI Manager and windows SDK version v4.6.21666.0428.
I am calling this after joining a meeting.

m_pMeetingService->GetMeetingShareController()->StartAppShare(hWnd);

It returns SDKERR_INTELNAL_ERROR. hWnd passed is a valid handle. If I call StartAppShare(NULL) or StartMonitorShare(NULL) which is supposed to share the primary monitor according to the documents, it returns SDKERR_INVALID_PARAMETER.

I checked m_pMeetingService->GetMeetingShareController()->CanStartShare(); and it returns true.

How I am supposed to get this working.

Thanks

Hi @balhara.vinay,

Thanks for the post. Is this reproducible with our demo app? If so, what are the steps to reproduce this issue? Could you also provide the SDK log so that we could further investigate?

Thanks!

Hi @Carson_Chen, I haven’t checked with the demo app. I have done same standard steps as in demo app just with custom UI manager. How can I send you the SDK log ? It is a binary .log file which I am unable to attach here since it is allowing only image files.

Thanks,
Vinay

Hi @Carson_Chen,
I have uploaded the SDK logs to google drive. Kindly find here:

Thanks

Hi @balhara.vinay,

Thanks for the reply and the SDK log. We are able to identify an issue that when calling the StartAppShare and StartMonitorShare and setting the parameter as null, the interface is not working as expected. We will fix this in the next release.

Regarding the other issue: The startAppShare in Custom UI is not working when passing a valid parameter. Based on the log file, since the log ends right after successfully joining a meeting, so it does not reveal the info for the screen sharing part.

For the 2nd issue, is this reproducible in our demo app?

Thanks!

@Carson_Chen Thanks for the effort. The error was caused by missing zcscpthost.exe. I was using only the zoom binary dlls assuming they were the only dependency. Looks like the other executables get spawned at runtime like zcscpthost.exe at the time of streaming. Putting the exe along fixed the issue for me.

Thanks,
Vinay