Invalid access token, does not contain scopes: [meeting:read:admin, meeting:write:admin]

getting below error while fetching meetings -

Invalid access token, does not contain scopes: [meeting:read:admin, meeting:write:admin]

Original request -
GET https://api.zoom.us/v2/users/shrihari.kale@indecomm.net/meetings?page_number=1&page_size=30&type=live

Headers:
Authorization: Bearer eyJhbGciOiJIUzUxMiJ9.eyJ2ZXIiOiIzLjAiLCJjbGllbnRJZCI6ImlySHMwUDRoU2h1VkJFVGNYWjI3dyIsImlzcyI6InVybjp6b29tOmNvbm5lY3Q6Y2xpZW50aWQ6aXJIczBQNGhTaHVWQkVUY1haMjd3IiwiZW52IjpbbnVsbF0sInVzZXJJZCI6IlNTcDU0SHREUlBLNDk3bUMtcWwtZkEiLCJhdWQiOiJodHRwczovL29hdXRoLnpvb20udXMiLCJhY2NvdW50SWQiOiJuUEd1NEQxZ1RjcU5aNHZEQnZrbmN3IiwibmJmIjoxNTUzMDg1Mjc0LCJleHAiOjE1NTMwODg4NzQsInRva2VuVHlwZSI6ImFjY2Vzc190b2tlbiIsImlhdCI6MTU1MzA4NTI3NCwianRpIjoiOWExODdhN2MtZTllMC00NjU0LWIzZWMtYjI3MGJlNWNkYTk3IiwidG9sZXJhbmNlSWQiOjB9.x4H1KKDeH-f5OrryMLXCT2Ns9KZaO8rRFf21vI5BYpwsy-7LlxjD6iaZUGmOrHrPDWPQqag13r5_QD10Qn-7Qg

Body:
undefined

If your OAuth requested meeting:read instead of meeting:read:admin, you might be able to use the “me” endpoint instead: /v2/users/me/meetings

Reference: https://marketplace.zoom.us/docs/guides/authorization/oauth-with-zoom/authentication-example

2 Likes

Thanks a Lot Jonathan!

Its working with “me” endpoint.

Thanks,

Shrihari

Hello Jonathan,

We are accessing Zoom APIs via programming. It is working fine however there will one manual intervention required – It is asking to
sign-in to get the authorization code.

We also tried – refresh token API to refresh access token, there also it is asking to sign-in.

Can we guide us – How can we skip manual sign-in process? OR is there any alternative?

Thanks,

Shrihari

You are using Zoom’s OAuth method, so that requires sign-in to approve access for a period of time. This method seems more beneficial for people who are offering services to other users, because those other users can approve your app to perform specific actions.

As far as I know, the only option that allows you to access the API without getting an authorization code is Zoom’s JWT method. The difference here is that JWT only works for an account that you manage, so since you have full access, it never needs to be “approved” manually. This is the method that I use, because I’m just trying to manage our one enterprise account and it lets me perform all the actions.

1 Like

I have tried JWT method, however getting below error -
{“code”:200,“message”:“Cannot use webinar API, You need to subscribe webinar plan and then enable webinar for this user: 4mRu9vIDSF-ROSgvAo5ZNA”}

Hi @shrihari.kale,

If your current plan type is basic, which doesn’t come with webinar plan, you would need to upgrade your plan type to PRO first, then subscribe to our webinar plan.

Fore more information, please visit: https://support.zoom.us/hc/en-us/articles/200917029-Getting-Started-With-Webinar

Thanks!

Hello Ojus,
I guess, we are on Webinar plan as well. From Zoom UI we can see and schedule webinars also from OAUTH API’s we can access webinar list.

It is issue with accessing webinar list using API with JWT.

Note: User List API is working fine with JWT.

Please guide.
Thanks

Hi @shrihari.kale,

This is unexpected behavior.

I was able to Create / Get list of webinars via JWT token.

Can you try testing the API here ?

Where it says oauth_access_token , add your JWT token, and try performing the operation.

Let me know if this helps.

Thanks!

Sorry for late reply.

As per previous suggestion, we are trying accessing API using “me” (Invalid access token, does not contain scopes: [meeting:read:admin, meeting:write:admin])
, Now we checked with User Id i.e. shrihari.kale@indecomm.net. Its working fine.

Thanks for all your support!

1 Like