Invalid Arguments (Error Code 150) iOS SDK with meeting password

Firstly, I am strongly behind the increased security that password protection provides, however, I have encountered a problem with iOS mobile SDK today when trying to start AND join a meeting using the meeting password. I am wondering if this is an issue with the new restrictions and if I am entering the meeting password correctly? I enter the password into an NSDictionary with the meeting number and then run join meeting with dictionary.

Version = 4.6.15084.0206

I was able to both start and join a meeting without password protection the day before the security changes were made.

A point in the right direction would be fantastic as this is restricting what I am able to do at the moment.

Thank you

Hi, I should update this and say I have tried further and still no joy. I have downloaded the latest version from github (version 4.6.15805.0403) and I am still using Xcode (Version 11.3.1).

The code that worked on Friday 3rd April to START A MEETING FOR A LOGIN USER was:

MobileRTCMeetingService *ms = [[MobileRTC sharedRTC] getMeetingService];
if (ms) {
MobileRTCMeetingStartParam *param;
MobileRTCMeetingStartParam4LoginlUser *user = [[MobileRTCMeetingStartParam4LoginlUser alloc] init];
param = user;
param.meetingNumber = zoomMeetingNumber;
MobileRTCMeetError ret = [ms startMeetingWithStartParam:param];
NSLog(@“onMeetNow ret:%d”, ret);

As I mentioned previously, this worked on Friday 3rd April but is now returning ERROR CODE 150 (invalid arguments). How can this be? The documentation does not state that a password is needed to start a meeting so I really don’t know what could be going wrong?

Joining a meeting is now fine and there are no issues. THE ISSUE IS WITH STARTING A MEETING IN-APP USING IOS SDK.

Rapid help would be much appreciated, I’m sure there is something simple I am missing.

Thank you

Hi danielrothwell,

Thank you for the post and the update. Your code snippet looks good, our demo app has the same implementation and I was able to start a meeting with our demo. Is this issue reproducible with our demo app?


Hi Carson,

Thanks for the response and your help.

I tried the demo app and was having the same problem, but then I noticed an error on my part - I was using the meeting password (rather than the account password) to login to zoom. I changed this in the demo app and my implementation and both are working now.

Thanks again for your help and apologies on my part for the oversight.

Hi danielrothwell,

Thanks for the reply. Glad to hear that it is working now. Happy Zooming! :slight_smile: