Problem joining meeting without password on iOS

Zoom SDK v4.4.55968.0904

Tried on iOS versions 12.1 & 13.1.2

I am able to join meetings without a password in Android but not iOS. According to the docs it should be possible, but when I try the methods below I get a dialog prompting for a password (see screenshot) and it won’t let me move forward unless I put something in, even if I pass an empty string to my enterMeeting method.

Also, when I add the [meetingSettings setEnableCustomMeeting:true] line, the dialog no longer shows but the onJoinMeetingInfo method is called with the MobileRTCJoinMeetingInfo value MobileRTCJoinMeetingInfo_NeedPassword.

How do I join a meeting without requiring a password on iOS? Thanks!

- (void)initSDK {
    @try {
        [MobileRTC initializeWithDomain:_webDomain enableLog:YES];
        _mobileRTC = MobileRTC.sharedRTC; 
        [_mobileRTC setMobileRTCDomain:_webDomain];
        MobileRTCAuthService * authService = [_mobileRTC getAuthService];
        NSLog(@"MobileRTC Version: %@", [[MobileRTC sharedRTC] mobileRTCVersion]);
        if (authService) {
            authService.delegate = self;
            authService.clientKey = _appKey;
            authService.clientSecret = _appSecret;
            [authService sdkAuth];
    @catch (NSException *e) {

- (MobileRTCMeetError)enterMeeting:(NSString *)meetingNumber withPassword:(NSString *) password andName:(NSString *)displayName {
    MobileRTCMeetingService * meeting = [_mobileRTC getMeetingService];
    meeting.delegate = self;
    MobileRTCMeetingSettings * meetingSettings = [_mobileRTC getMeetingSettings];
    [meetingSettings setEnableCustomMeeting:true];
    NSDictionary * meetingParms = @{
    return [meeting joinMeetingWithDictionary:meetingParms];

Hi awk,

Thanks for using Zoom SDK. If the dialog shown in the screenshot pops up, it means the meeting has a password. Just would like to confirm:

  • Are you able to join the same meeting from Android without password but not able to join the meeting on iOS? Are you able to join the same meeting using our Zoom client?
  • Could you provide the steps to reproduce this issue?


Thanks for getting back to me!

So, I created a meeting without a password from the Mac app and was able to join using the Android sample, the Windows client and from a browser on another Mac. I was not able to join the meeting from the sample application on iOS. On the sample there are fields for meeting id and password. I put the meeting id in, hit ok, and the dialog is dismissed but nothing happens. Just to be clear, the iOS sample has not been modified.

Thanks again for the help.

Hi awk,

Thanks for the reply. Actually I just tried the steps you are mentioning: I started an instant meeting(no password) with Zoom Mac client, and I use the iOS demo app to join the meeting (logged in and not logged in), and I am able to join the meeting without any password.

When you said “The dialog is dismissed but nothing happens”, are you getting any responses or error codes after this? Could you print out the return value of [meeting joinMeetingWithDictionary:meetingParms];?


Although I can’t explain why, the iOS sample and the original code that I had a problem with are now working. I’m now receiving MobileRTCMeetError_Success. If I have any more issues I will write back, but for now I guess we can chalk it up to user error when creating the meetings. Thanks again for your help and timely replies.

Hi awk,

Glad to hear that now everything is working. Please let us know if you are facing any other issues. Happy Zooming! :slight_smile: