Invalid redirect (4700) during oauth flow

Description
We have received reports from users of an “invalid redirect” error when they attempt to authorize our app in the marketplace.

As the developer, I am also now experiencing the issue, though had no issue when the app was first published and approved. I am not seeing the issue in our development environment, using the development credentials

Error
Invalid redirect: https://app.scoir.com/oauth/zoom/result (4,700)

Which App?
Scoir Office Hours

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Open “Publishable URL”
  2. See error

Additional context
I created a new zoom account (basic) and am not seeing the issue. Our belief is that it’s related to the user accessing the oauth flow, not the marketplace app settings.

Hey @dayne,

Thanks for reporting this, we will work on fixing it asap. (/ZOOM-162618)

-Tommy

Hey @tommy,

Thanks for looking into this. I’m wondering if there is any progress in resolving the underlying issue or if there is more information that’d be helpful from our end.

Thanks,

  • Dayne

Hey @dayne,

All I need was the app name which you provided. Apologies for the delays, I have just prioritized this.

If you want an immediate work around, you can create a new OAuth app.

Thanks,
Tommy

Hey @dayne,

Please check to see if it works now. :slight_smile:

Thanks,
Tommy

Hey Tommy,

Same result as before. I’ve tried both logged out and already logged into zoom, both methods are receiving the same “Invalid redirect” error page

Hey @dayne,

Your app is named Scoir Office Hours right? I have requested priority to fix it.

Thanks,
Tommy

1 Like