Issues with webrtcsession while using the electron SDK


#1

Hi!

I’ve been using the zoom electron SDK successfully for several days. Today, suddenly, I started getting the following error when I do the SDK authentication:

[17848:1116/115434:ERROR:webrtcsession.cc(1226)] ConnectDataChannel called when data_channel_ is NULL.

The SDK authentication call causes the apicallresultcb callback to be called with the  apiname of SDKAuth and the ret value of SDKERR_SUCCESS.

The SDKAuthcb callback also gets called and the status it receives is  AUTHRET_SUCCESS

When this happens, the system does not proceed to logging the user in.

If I try to start a meeting, I get the error:

SDKERR_WRONG_USEAGE in the callback apicallresultcb

This worked fine with the same credentials a couple of days ago and now this happens consistently.

The only thing that happened in the interim is that I built an installer and installed the system on another computer. This started happening there, but now it also happens on my dev computer.

What changed?

What am I doing wrong?

 

Thanks,


#2

hi,

i think it is the wrong user type you used. we have two user type to choose. api user or login user.

1> 

StartMeeting and JoinMeeting in the zoom_meeting.js are for login user.

2>

StartMeetingWithOutLogin and JoinMeetingWithoutLogin in the zoom_meeting.js are for api user.

 

could you please to check your code?

thanks

dats


#3

Hi!

Thanks for your response. My code is based on the Zoom Electron demo. The code there definitely uses the StartMeeting, not the StartMeetingWithOutLogin. I can tell you that it worked great with my API key and secret along with the username and password.

However, I think that the SDK initialization is failing before that becomes relevant. The SDK authentication seems to fail with the error I mentioned. you get that before you start the meeting, it happens when I call SDKAuth in this call:

zoomauth.SDKAuth(appkey, appsecret).

I think that once that fails, everything that happens after is not relevant anymore.

 

Ilan