Language Interpretation not available

My account has Pro plan + Webinar add-on and I can not enable the language interpretation option for my meetings. I was following this link but I don’t have Language Interpretation option. Also, I will need to enable this functionality when I am creating the meetings using the Zoom API.

Which Web Meeting SDK version?

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to the zoom profile
  2. Click on Settings
  3. Scroll down to In Meeting (Advanced)
  4. Result: there is no Language Interpretations option to be enabled.

This is the picture of my Zoom meeting created with the API and Web SDK.
As you can see, the Language Interpretations button is missing.

Device (please complete the following information):

  • Browser: Chrome
  • Browser Version Version 96.0.4664.45 (Official Build) (64-bit)
1 Like

Hi @aleksandarar ,

Happy to help. Are you following the directions for Account, Group, or User?

Can you send the screenshot and a link to this thread to because the screenshot you’ve shared is not displaying your settings.


Hello @gianni.zoom,

The support team enabled Language Interpretations on my account, but when I create a meeting with the API and I start it with the SDK on my application the functionality is missing.
This is how I create the meeting with C#:

var client = new RestClient(string.Format("{0}users/me/meetings", _appSettings.ZoomApiUrl));
var request = new RestRequest(Method.POST);
request.AddHeader("content-type", "application/json");
request.AddHeader("authorization", "Bearer " + accessToken);
object jsonParam = new
                topic = meetingName,
                type = 1,
                settings = new
                    waiting_room = false,
                    mute_upon_entry = true,
                    language_interpretation = new
                        enable = true,
                        interpreters = new object[1]
                            new {
                                email = "",
                                languages = "US,CN"

            request.AddParameter("application/json", jsonParam.ToJson(), ParameterType.RequestBody);

and this is how I start and join the meeting with the host with Angular 9:

startMeeting(signature, isHost) {

    var self = this;

    const meetConfig = {
      apiKey: settings.zoomApiKey,
      userName: currentUser.FirstName + ' ' + currentUser.LastName,
      userEmail: currentUser.Email,
      role: '1'

      leaveUrl: settings.zoomApiLeaveUrl + '/#' + this.router.url,
      isSupportChat: false,
      isSupportQA: false,
      isSupportCC: false,
      screenShare: true,
      showMeetingHeader: false,
      showPureSharingContent: false,
      // on success, call the join method
      success: function (success) {
          show: false

          // pass your signature response in the join method
          signature: signature,
          apiKey: meetConfig.apiKey,
          userName: meetConfig.userName,
          passWord: self.meeting.password,
          userEmail: meetConfig.userEmail,
          success(res) {
              success(response) {
                var data = {
                  userEmail: meetConfig.userEmail,
                  userZoomId: response.result.currentUser.userId
                self._zoomPlayerService.insertUserZoomId(data).subscribe(result => {
                  self.zoomParticipantsCount = result;

              show: true
          error(res) {

This is how Zoom looks like in my application after starting it with the code mentioned before.

EDIT: If I join the meeting with Zoom for desktop then Language Interpretations button is available. If I click it I can assign interpreters and if I click Start the button for language interpretations is shown in the application which is using the Web SDK.
So, the problem is that I can not start the Language Interpretations from the web application which is using the SDK.

1 Like

Hi @aleksandarar ,

Sorry for the delay!

This makes sense and is expected behavior as the prerequisites for Language Interpretations button include the desktop or mobile client:

Thank you,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.