Meeting that requires authentication won't connect

A clear and concise description of what the question is.
When I try to login into a meeting that requires authentication in a clean build of the meetingsdk-web-sample, the helper popup stays blank and won’t connect after I click in “sign in”.

Browser Console Error
There is no error in the console.

Which Web Meeting SDK version?

Meeting SDK Code Snippets
This is the hosted clean build of meeting-sdk:

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to
  2. Connect to a call that requires authentication
  3. Click on “sign in”
  4. A white pop-up will appear


Device (please complete the following information):

  • Device: MacbookPro M1 Max
  • OS: macOS 13.4.1
  • Browser: Chrome
  • Browser Version: 117.0.5938.132

Additional context
I can login when I’m on localhost, but not when I host it on vercel.

It’s been 13 days with no answer, I’m posting so it is not closed automatically

It’s been 29 days without responses, would someone kindly help?

Hey there - sorry for missing this - looking into what this could be now.

Which version of the sample are you using - Local, CDN, or Components? Also - if you have a public repo or anything a link to that would be helpful.

I’m running version 2.18.0 using CDN. Here is the public repo:

1 Like

Thanks for sharing - I will take a look and get back to you.

The signature is invalid when attempting to join a meeting, so I would start by verifying what’s generated using your app credentials, and that Vercel has correct access to them (environment variables, most likely).

You can validate your signature using this guide → Troubleshooting Meeting SDK signature validation

I can join meetings without authentication required, it is just meetings with authentication that gives the blank screen. Have you tried to join using the application I hosted? If you try joining a meeting without authentication required it is going to work

@kellyjandrews Hi Kelly, I’m bumping this up so it is not closed automatically. Please see my last response.

Hi @Felippe
I took a look at your app and it looks like this is expected behavior. I tried joining a meeting using your application here is what happened:

  1. When I tried to join as a host, I got an error (signature invalid) and this I believe is expected, because the credentials used to generate the signature are tied to your account, not to mine, so this is expected. I will continue getting this error if I try to join as a host
  2. When I started the meeting in the client app as a host, I was able to join the meeting as a guest using your app (with No authentication required)
  3. When I started the meeting in the client app as a host, I was not able to join the meeting as a guest using your app because authentication is required and this is what I see:

I’m confused with the 2 and 3, because they both start in the same way in the sentence. Did you perhaps intended to write something else?

And has the “NOT _CONNECTED ERROR AUDIO” something relevant?

Hi @Felippe
for 2 and 3, I started the meeting on my Zoom client directly and then in point 2, I tried joining the meeting using your deployed sample app and I was able to join as a guest (the meeting had no authentication required)
For point 3, I did the same meeting but the meeting had authentication required and it failed

@elisa.zoom Is there any sample backend example of how I should be generating a singature correctly?

Hi @Felippe
Here is a sample app GitHub - zoom/meetingsdk-auth-endpoint-sample: Generate a Meeting SDK JWT to join Zoom meetings and webinars with the Meeting SDK.

But remember, when I test with your deployed app and try to start the meeting I will always get signature invalid because the signature is being generated with your credentials, so it is expected

@elisa.zoom What should I do to allow anyone to log in an authenticated meeting using my app?

You will have to publish your app in the Marketplace team

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.