Metrics past meetings participants details

I’m trying to get the details that we can see on the past meetings’ dashboard, when you click on the ID it’ll open up another page with the participants details.
I’m using GET metrics/meetings/{meetingId}/participants endpoint, on meetingId it says that you can provide the meeting UUID to retrieve the specific participants details of that day, but I’m getting a “Meeting does not exist: .” error message, even using the meetingId to get the details of a live meeting, it returns the same error.

Hi @aevirtualclass , how far into the live meeting are you querying this endpoint? Do the meeting details return on this endpoint when the meeting has ended?

Hi, thank you for the follow-up of my inquiry.
I have managed to get the participants details of a live meeting, but it’s not my main purpose, what I’m trying to achieve it’s to get past meeting’s participants details, and here it’s where I’m having the error message “Meeting does not exist: .”, what am I missing?

I read on another article to use past_meetings/[meetingId]/instances endpoint to get the correct meeting UUID , that’s what i’m using to try to get the details.

Hi @aevirtualclass ,

Apologies I overlooked the title of this thread! To get past meeting info you can use with type=past for the query string parameter.

If you do not need the metrics data returned to that endpoint, you are correct that you can use instead!

Here it’s how I’m setting the API call, when I change the type to “past” it’s when I’m getting the error message using the ID or the UUID for the specific date that I need

Api call settings

This is the error

Error message

@aevirtualclass , what do you receive when you use the second endpoint I linked? I want to see if it’s an issue with the uuid or the first endpoint.

I have no problem with the second endpoint, using the UUID
past meetings participants

@aevirtualclass , can you please try calling the endpoint on Postman and see if you are successful?

I tried to do the request again, and I receive a successful response using the UUID, I don’t know what it was, but it works perfectly now. Thank you for the support.

Postman API CALL

Okay @aevirtualclass , double check your code/how you were calling the API compared to the Postman workspace! Glad it’s resolved.