Need to create URLs that do not use our vanity subdomain

Our zoom account has SSO enabled for some of our full time staff and then we have a large number of volunteers that sign in using a Zoom account and password.

When we use “meetingcreate” from the API all of the generated URLs include our vanity subdomain. For our volunteers that we provide Zoom accounts to this causes an issue because the sign in page for them features SSO rather than Zoom account sign in. If I manually remove our subdomain from the URL the page they go to features the Zoom account sign in.

We want the generated URLs to just use “zoom.us” as the domain and not “.zoom.us”. Is there a setting or a parameter we need to change?

Which Endpoint/s?

Hi @guavamnia,

Thanks for reaching out about this—I can definitely appreciate your use case here.

At the moment, there’s not a way to prevent your subdomain from being included with the join_url, though I think your use case is a good example of how having more control over this could be helpful.

For now, my recommendation would be to consider removing this programatically from your end—for example, you could use some JS to remove this from the link before you send it out.

Having said all of this, if you’re so inclined, this could be a great addition to our #feature-requests channel as well.

Best,
Will