New recurring meeting not showing up


#1

I have successfully sent a POST request to create a new recurring meeting. The response is 201 and the body looks great. But I don’t see the meeting in My Meetings page. When I try to join the meeting using the join_url I get a “Invalid meeting ID.” error.

I can retrieve the meeting just fine.

https://api.zoom.us/v2/meetings/907612516

Also note that when I create a non-recurring meeting it shows up in My Meetings. The problem is only with recurring meetings.

Here is a sample request:

{
    "topic": "A sample meeting",
    "type": 8,
    "start_time": "2018-12-10T00:00:00",
    "timezone": "America/New_York",
    "recurrence": {
        "type": 1,
        "repeat_interval": 1,
        "end_date_time": "2018-12-14T23:59:00"
    },
    "settings": {
        "host_video": false,
        "participant_video": false,
        "mute_upon_entry": true,
        "audio": "both"
    }
}

#2

I have found the problem. The end_date_time has to be in GMT. So changing this to something like “2018-12-14T23:59:00Z” resolved the problem. Now the meeting shows up and I can use the join url.


#3

Hi @bibhas.bhattacharya,

Glad you were able to resolve the issue. Let us know if you need any more help!


#4

You may wish to open a defect. The REST call should fail if end_date_time is not in GMT.


#5

Should it result in a bug if you are able to set the timezone offset using the ISO 8601 format for the input?


#6

Hi @bibhas.bhattacharya,
You’re correct, if it’s a recurring meeting the API should throw an error letting you know that the end_date_time should be in GMT format instead of sending a successful 201.

I’ll report this to the Engineering team for them to investigate.

Thanks