No option to show/hide the meeting ended message

Couldn’t find an option to show/hide the meeting ended message “The meeting has been ended by the host” in iOS SDK.

Prior to 5.2.41735.0928 version it used to come automatically after the host has ended the call. But from this version upgrade this alert is not coming. Seeing the release notes looks like it is done intentionally. Here is the relevant info from that 5.2.41735.0928 release notes

  • Fixed an issue that the "The host has end the meeting " alert can not be hidden.

But we would like to show that alert once the meeting is ended by the host, but don’t see any option in iOS SDK to show/hide the meeting ended alert. When we integrated the earlier version the alert used to come without specifically enabling it. Saw that there is option to show/hide alert in Android SDK.

Which version?
5.2.41735.0928 and later

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Make a Zoom call from User A to User B.
  2. From User A who is the host end the call.
  3. User B can’t see “The meeting has been ended by the host”

Screenshot 2020-12-18 at 8.21.54 PM

Smartphone (please complete the following information):

  • Device: [e.g. iPhone X]
  • OS: [e.g. iOS 13.1]
  • Version [e.g. 22]

Additional context
Looks like this is an intentional fix done by Zoom in that version that users are unable to hide the alert. But going through the API there is no option to show the alert, we can do ourselves in meeting ended delegate method, but would like to know if it is there or not and if planning to add it in future.

Hey @kiran_xcube,

Thanks for using the dev forum!

Looking into this one now, you are using the Default meeting UI, correct?


Yes Michael, using the Zoom default meeting UI.

Thanks for looking into it.

Hi @Michael_Condon ,

Hope you are doing great. It’s been few days since I gave the reply, haven’t heard back from you. Let me know if you need some more information.


Hey @kiran_xcube,

I looked into this on version 5.2.41735.0928 and the latest version and saw the meeting ended by host message both times. Can you try and reproduce this in the sample application?

For reference, this is the code I used:

func initialzeSDK(withSDKKey key: String, andSDKSecret secret:String, appGroupID: String, authDelegate: MobileRTCAuthDelegate) {
        let mobileInitContext = MobileRTCSDKInitContext()
        mobileInitContext.domain = ""
        mobileInitContext.appGroupId = appGroupID
        mobileInitContext.enableLog = true
        if MobileRTC.shared().initialize(mobileInitContext) {

            if let authService = MobileRTC.shared().getAuthService() {
                authService.clientKey = key
                authService.clientSecret = secret
                authService.delegate = authDelegate


func joinMeeting(withMeetingNumber number:String, andPassword password: String, userName: String, useCustomMeetingUI: Bool, meetingServiceDelegate: MobileRTCMeetingServiceDelegate) {
        if let meetingService = MobileRTC.shared().getMeetingService(),
           let meetingSettings = MobileRTC.shared().getMeetingSettings() {
            meetingService.delegate = meetingServiceDelegate
            meetingSettings.enableCustomMeeting = false

            let joinMeetingParameters = MobileRTCMeetingJoinParam()
            joinMeetingParameters.meetingNumber = number
            joinMeetingParameters.password = password
            joinMeetingParameters.userName = userName

            let joinMeetingReturnValue = meetingService.joinMeeting(with: joinMeetingParameters)

            switch joinMeetingReturnValue {
            case MobileRTCMeetError_Success:
                print("Join meeting successful")
                print("Could not join meeting. Error: \(joinMeetingReturnValue)")


Hi @Michael_Condon ,

I tried with latest SDK as well with no luck. Here is the initialisation code and the meeting settings used, not sure which setting is causing the alert to hide.

Initialisation code:

let context: MobileRTCSDKInitContext = MobileRTCSDKInitContext()
        context.domain = ""
        context.enableLog = true
        context.locale = .default
        context.appGroupId = ""
        let initSuccess: Bool = MobileRTC.shared().initialize(context)
        return initSuccess

Here are the meeting settings used

if let meetingSettings = MobileRTC.shared().getMeetingSettings() {
            meetingSettings.topBarHidden = false
            meetingSettings.meetingTitleHidden = false
            meetingSettings.meetingPasswordHidden = true
            meetingSettings.meetingShareHidden = false
            meetingSettings.meetingMoreHidden = false
            meetingSettings.meetingChatHidden = true
            meetingSettings.meetingInviteHidden = false
            meetingSettings.hintHidden = false

Let me know if some setting or option that needs to be switched on to get the default ZOOM alerts, because as per the SDK release 5.2.41735.0928 release notes

  • Fixed an issue that the "The host has end the meeting " alert can not be hidden.
    After this release that alert stopped, but haven’t seen any method to enable/disable alerts.


Hey @kiran_xcube,

I am not seeing an interface to hide/show this alert manually. Can you run the sample application and let me know if you see the same behavior?


Hi @Michael_Condon ,

I tried this with the Zoom sample application and I could see the “This meeting has been ended by the host.” message on participant device when host ends the call.

I don’t see any major differences in the sample code and our code, I even copied the same meeting settings from our app to sample app and still the alert came. Not sure which is causing the alerts to hide in our code. But certainly related to the fix done in 5.2.41735.0928. Fixed an issue that the "The host has end the meeting " alert can not be hidden.

Before that release we could see alerts but after that release we don’t see alerts, there is no change in code from our side. Just updated the Zoom SDK.



Hey @kiran_xcube,

Hmm, that is very interesting. This is going to need some deeper investigation. Would you be able to email

In the email, please provide the following: