Oauth authorization response - empty scope

I am working on integration, of an app I work on, with zoom.
I have followed api doc, for Oauth api.
I have created an app, in zoom marketplace, of Oauth type.
I have copy pasted the api key, and api secret values into my app.
and I also provided a redirect url into zoom.
When I hit the endpoint


I got an error message:
Empty scope (the client doesn’t have any scope) (4,700)

don’t really know why.
I think my account doesn’t have admin privileges - can it be the root cause?

Empty scope (the client doesn’t have any scope) (4,700)

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)

Additional context
Add any other context about the problem here.

Hey @adam_krawiec,

Do you have any scopes on the scopes page?


The same problem appeared for me, I have scopes on the scopes page

Hey @ilia,

Can you share more details about this issue? What type of App, Chatbot, User Level OAuth, or Account Level OAuth?

When is this error thrown, when trying to install your app?


I’m running into the same problem with a Chatbot I’m setting up. The only scope I have set is “imchat:bot”. I get the message when I go to install the bot under “Test the App Locally”. The message shows up instead of the blue “Authorize” button.

Empty scope (the client doesn’t have any scope) (4,700)

Thanks for any help! I may be missing something simple. I have used OAuth once before to set up a chatbot on a different platform, but this is my first time working with your API. If you follow the documentation here, the problem may be repeatable for you. Let me know if I can provide any other information.

~ Andrew

I’m getting the same ‘Empty scope’ message. Just tried to create a chat bot app with scope ‘imchat:bot’.

The error appears only when scope “imchat:bot” is added automatically. I found a workaround: I added any second scope to my app -> save changes-> remove previously added scope -> error disappear

Exactly. I added some other scopes and removed them again. But still cant get it running. I’m always getting that I’m not able to authorize the app.

Hey @oliver.webb, @andrewolmstead, @ilia,

We are looking into this and will get back to you! (ZOOM-147500)

If you could share screenshots of the issue that would help.

Apologies for the inconvenience.


We are seeing this issue as well on a new app. The scopes we added in marketplace ui appear to have been altered to split the read and write scopes for meetings and webinars… perhaps this is related.


Thanks for looking into this! I tried testing the app locally again, and it brought up the authorization page successfully, so the “Empty scope” message is gone.

However, when I continue and click authorize, the Zoom client on my PC opens with the error “Failed to Open Chat”. I’ve included a screenshot. The chatbot doesn’t show up under “APPS” in the actual Zoom client. It doesn’t look like it’s installed.

In the browser, it says the app was authorized and installed successfully. The “preview url” shows I am subscribed to the bot. When I uninstall the app, I don’t get any errors, it just says “Uninstall successfully”.

Thanks again for your help. Let me know if there’s any other information you’d like! I am new to these forums so I am only allowed to include on screenshot at a time.

~ Andrew

I also seem to be getting the same issue.
I was able to temporarily resolve the issue by removing the scopes and then adding them back. But then after an hour or two, the issue came back. (note: this no longer seem to work)

Screenshot of error screen:

Hi @toast38coza @andrewolmstead @aaron,

Thank you for reporting this. Our Engineering team is working diligently on fixing this issue. We will post an update on this thread as soon as we have more information.


I have received the same error message after I tried to automatically integrate Zoom from Doodle today :frowning:

Same issue here. OAuth screen loads correctly when I’m logged into the same account used to develop the app, but get that same “empty scope” error when either not logged in to Zoom, or when logged into a different Zoom account. And this is using the “publishable” url, not the test credentials.

Hi there.

Just checking in if there’s any progress on this?
Alternatively, if there are any work-arounds?

Hey @toast38coza, @ryanmoody, @robert.dankanin, @toast38coza, @andrewolmstead, @aaron, @oliver.webb, @ilia,

​This issue is caused by some of our servers being out of sync between web clusters.

We are working to fix the issue. Can you share your app’s client ID (they are public so ok to share on forum) so we can fix your apps in the meantime?

A possible workaround would be to try making a new app.


Hi Tommy

Thanks for your prompt reply in what I know must be a very busy time for you!

My client ids are:
Prod: N1F8JnhKTIiMNhHfl2LV3g

Hi @tommy,

my client ids are:
Dev: 3wm_oGHxR5GDACFklTd9ww
Prod: PAs6llCTQ2FeWHGE5sBg

Thanks @tommy!

I have 2 apps
First one:
Prod: 6LEXSE27RE6PMvO_camjqA

2nd app:
Dev: c2tRTjePRbCAGYwYnMmbag
Prod: rk7csw1KRkmmmFcOURzkA