OnUserLeave signal received when calling AdmitUser if user is in waiting room

Description
Our application has moderator and respondent roles. Moderator suppose to put respondents to waiting room and restore them. Code works fine in the beginning of November, but now situation is different.
Moderator can put user to waiting room, but he cant move user from waiting room back to the conversation.

Here is how we do it:
On moderator side, we call AdmitUser function to return user back to the conference

On user-in-waiting-room side we receive OnUserLeave instead on OnMeetingStatusChanged with param MeetingStatus.MEETING_STATUS_INMEETING

Which version?
version 5.0, we tried update to 5.2 but app crashed during sdk initialization

To Reproduce(If applicable) not applicable

Screenshots not applicable

Device (please complete the following information):

  • Device Spec: PC
  • OS: Windows 10
  • Version 1909 build 18363.1256
    We tried several different computers (4) with windows 10, same problem everywhere

Additional context
Add any other context about the problem here.

Hey @yuriy,

Thanks for using the dev forum!

I will try to reproduce the waiting room issue you are seeing. In the meantime, I am curious about the 5.2 crash. Can you provide any further info regarding that?

Thanks!
Michael

We fix it by update to 5.2.1

Same bug returns in 5.2.1 after a while. However it apply only if application is installed in Program Files folder.
If application is installed into user’s home folder - application works fine. No files are written info application folder by our code and I do not see any new files created by anyone else.
If I run the application as administrator - problem still exist.

I’m out of ideas, help )

Hey @yuriy,

To make sure I am understanding correctly, you are seeing a bug where admitting a user into the meeting causes the onUserLeave callback to trigger sometimes. This bug only happens if the application is installed in the Program Files folder.
Is this correct?

Thanks!
Michael