Participant doesn't hear anyone if he doesn't allow access to audio

Description
Participant doesn’t hear anyone if he doesn’t allow access to audio. But he hears everyone between stream.startAudio() and clicking ‘block’ on access to audio popup.

Which Web Video SDK version?
1.1.0

To Reproduce
Steps to reproduce the behavior:

  1. stream.startAudio()
  2. Now user hears everyone and browser asks access to audio
  3. User doesn’t allow access to audio
  4. User doesn’t hear anyone

Screenshots
If applicable, add screenshots to help explain your problem.

Device (please complete the following information):

  • Device: desktop
  • OS: Win10
  • Browser: Chrome latest version

Hey @mx_ryabov

Thanks for your feedback. Audio popup is to control microphone permission, so the speaker can still work.

Thanks
Vic

I checked this case in your demo app. After access blocking to microphone I doesn’t hear anyone.

Hey @mx_ryabov ,

Are you saying that the audio works at first, but after the user clicks “block” audio, then there is no more sound? Do you see any error messages in the browser console?

Thanks,
Tommy

Yes. Audio works at first (but not microphone), but if user clicks “block” audio (that is, blocks access to microphone), then there is no more sound.

Do you see any error messages in the browser console?

yes (screenshot from your react-demo)
image

Thank you @mx_ryabov , we will take a look at this. (ZOOM-287814) CC @vic.yang

-Tommy

1 Like

Hey @mx_ryabov ,

We will work on fixing this bug.

In the meantime, the workaround is to enable the mic permissions, and go on mute. Then the user will still hear the audio.

Thanks,
Tommy

1 Like

Hey @tommy, is there any time frame for this bug fix? It severely impacts our use case and were initially told it was supported as before we implemented Zoom’s Video SDK. Any updates are appreciated!

Hey @seth ,

This is on our roadmap to fix. You can stay updated here: https://marketplace.zoom.us/docs/changelog

In the meantime, the workaround is to enable the mic permissions, and go on mute. Then the user will still hear the audio.

Thanks,
Tommy