Ramdom Crash - java.lang.UnsatisfiedLinkError

Description
I have followed the integration steps as per your docs but I am facing java.lang.UnsatisfiedLinkError crash randomly. I have tried using zoom SDK version 5.4.3.603 and 5.2.42043.1112, app is crashing in both versions. I have tried a lot to solve it but unable to do so. I have tried abiFilters as well but it does not make any difference. Hoping to hear from you soon.

Which version?
zoom SDK version 5.4.3.603 and 5.2.42043.1112.

To Reproduce(If applicable)
Steps to reproduce the behavior:
Initialize the SDK.

Smartphone (please complete the following information):
Lenovo TB-8704X

Hi @ahmed2, thanks for the post.

Sorry to hear you are running into a crash with the SDK. Can you please provide the full stack trace from the crash so that I can take a look at how we can resolve this?

Thanks!

Thanks for the reply @jon.lieblich.

Please check below the stack trace.
java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file “base.apk”],nativeLibraryDirectories=[/lib/arm, /base.apk!/lib/armeabi, /system/lib, /vendor/lib]]] couldn’t find “libc++_shared.so”
at java.lang.Runtime.loadLibrary0(Runtime.java:984)
at java.lang.System.loadLibrary(System.java:1530)
at com.zipow.cmmlib.AppContext.(AppContext.java:36)
at com.zipow.cmmlib.AppContext.initialize(AppContext.java:71)
at us.zoom.sdk.ZoomSDK.initialize(ZoomSDK.java:466)
at InitAuthSDKHelper.initSDK(InitAuthSDKHelper.java:56)
at InitAuthSDKHelper.initSDKWithListener(InitAuthSDKHelper.java:79)
at nitializeZoomSDK
at initialization
at onCreate
at android.app.Activity.performCreate(Activity.java:6720)
at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1119)
at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2618)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2726)
at android.app.ActivityThread.-wrap12(ActivityThread.java)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1477)
at android.os.Handler.dispatchMessage(Handler.java:102)
at android.os.Looper.loop(Looper.java:154)
at android.app.ActivityThread.main(ActivityThread.java:6119)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:886)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:776)

Hi @ahmed2, thanks for the additional info.

Can you please confirm that you are correctly importing both the mobilertc.aar and commonlib.aar modules into your project according to the steps outlined here? If these steps are followed, you should also see two lines in your build.gradle file’s dependencies block for these modules.

Thanks!

Yes @jon.lieblich, I have followed the steps as they are described in the docs and imported both the modules mobilertc.aar and commonlib.aar. Also I have made sure that my gradle build file consists implementation project(’:commonlib’), implementation project(’:mobilertc’). And my settings.gradle file also consists include ‘:mobilertc’, include ‘:commonlib’. Still I am having that crash randomly while zoom initialization.

Hi @ahmed2, thanks for confirming that.

Can you please try updating to the most recent version of our SDK? Let me know if the issue still persists on that version.

Thanks!

I have already tried above latest version I have found. Please suggest newer version so that I can try.

@ahmed2 The sdk only support ‘armeabi-v7a x86 arm64-v8a x86_64’ cpu architecture.

If you project have native module,you can add ndk { abiFilters 'armeabi-v7a x86 arm64-v8a x86_64' } in the build.gradle