Recurring meeting GET /meetings/{meetingId} no recurrence object

I’m attempting to retrieve meeting details for recurring meetings.
First i created meetings with POST users/{mail@adress}/meetings. response not contains end_date_time and start_date. but in the response type is still 3.
Then i try to get meeting details GET meetings/{meetingId}. but response not contains recurring meetings.

My meeting id is 89995699101.

i am super confused, zoom type is 3 but there are no recurring meetings. is it a recurring meeting or not? if it is why i cant get recurring meeting details.

its really urgent, thank you

(by the way some one asked this question but referenced link is broken
GET /meetings/{meetingId} No recurrence object.
broken link:
thank you)

Hi @zethmentor ,

First, here’s the new docs page:

Secondly, can you please share your full post request/response?

Thank you,

Hi @gianni.zoom, thanks for quick reply :))).
“timezone”: “Europe/Istanbul”,
“password”: “000000”,
“agenda”: “string”,
“duration”: 50,
“zoomType”: 3,
“start_time”: “2022-02-07T13:22:32.451Z”,
“topic”: “last topic”,
“type”: 3,
“recurrence”: {
“type”: 2,
“repeat_interval”: 1,
“weekly_days”: “2,3”,
“end_times”: “5”

“uuid”: “REDACTED”,
“host_id”: “REDACTED”,
“host_email”: “REDACTED”,
“topic”: “last topic”,
“type”: 3,
“status”: “waiting”,
“timezone”: “Europe/Istanbul”,
“agenda”: “string”,
“created_at”: “2022-01-29T17:03:51Z”,
“start_url”: “REDACTED”,
“join_url”: “REDACTED”
“password”: “000000”,
“h323_password”: “”,
“pstn_password”: “”,
“encrypted_password”: “REDACTED”,
“settings”: {
“host_video”: false,
“participant_video”: false,
“cn_meeting”: false,
“in_meeting”: false,
“join_before_host”: false,
“jbh_time”: 0,
“mute_upon_entry”: false,
“watermark”: false,
“use_pmi”: false,
“approval_type”: 2,
“audio”: “voip”,
“auto_recording”: “none”,
“enforce_login”: false,
“enforce_login_domains”: “”,
“alternative_hosts”: “”,
“close_registration”: false,
“show_share_button”: false,
“allow_multiple_devices”: false,
“registrants_confirmation_email”: true,
“waiting_room”: false,
“request_permission_to_unmute_participants”: false,
“registrants_email_notification”: true,
“meeting_authentication”: false,
“encryption_type”: “enhanced_encryption”,
“approved_or_denied_countries_or_regions”: {
“enable”: false
“breakout_room”: {
“enable”: false
“alternative_hosts_email_notification”: true,
“device_testing”: false,
“focus_mode”: false,
“private_meeting”: false,
“email_notification”: true
“pre_schedule”: false

Ahh I see @zethmentor ,

This is expected API behavior. Type 3 recurring meetings have no start or end time. They are considered a recurring meeting with no fixed time. You can test this out in your Zoom Portal as well:

  • Go to "schedule a meeting
  • Select “recurring meeting” under Timezone
  • Click the “recurrence” drop down and select “no fixed time” and you’ll see all the time parameters disappear like this:

If you went to set a specific time, you have to create a Type 8 meeting.

Thank you,

@gianni.zoom thank you i got it :))

1 Like

Okay great! Happy to hear that!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.