ReferenceError: _ is not defined

I am integrating ZoomSdk client view, but i am facing errors in the import and itseld

import { ZoomMtg } from "@zoom/meetingsdk";


i dont understand what this error is, this is caused becuause of these ZoomMtg.preLoadWasm();

i am using
react + typescript app with vite

 "react": "^18.2.0",
 "@zoom/meetingsdk": "^3.1.6",
1 Like

I am getting the same issue, if i import embedded package then it is working fine

Like " import ZoomMtgEmbedded from ‘@zoom/meetingsdk/embedded’; " is not causing any error but
import { ZoomMtg } from ‘@zoom/meetingsdk’;
this is getting me this _ is not defined error

Does any one have solution ?

I’m having the same issue since rebuilding our existing Zoom integration. I can’t see where I’m missing what’s clearly a crucial bit of config at the moment but if I find it, I’ll let you know

Hey Mike, Thanks,
Actually I have solved this _ issue , it was because of the zoom lodash library was not loaded so i added <script src=""></script> in my index.html file in header tag in my ReactJS app and error is solved
Hope this helps to you

1 Like

Thanks for sharing @abhay.scaleteam! Unfortunately I haven’t figured out my issue yet but I’ve parked it for now. I have an Angular project within an Nx monorepo, although never had an issue like this with any other package.

Hi, I am having the same error.

I would prefer not to import lodash globally from the Zoom CDN. Is there another option?

Same issue here also. I am using vite btw. Component view runs ok but it missing whiteboard some reason. I am tired of those issues

I am also having the same issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.