Registrants_email_notification seems to have no effect

I’m creating meetings with the api and have been passing registrants_email_notification as false under the settings property but it seems to have no effect.

Screenshot from documentation at https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate

Example of request being made:

Despite passing that as false, I’m still seeing this on the created meeting:

My goal would be for that meeting to have those emails disabled.

Hi @okzoomer if you send "registrants_email_notification": false (lowercase boolean value), this should return the correct response. Can you try this and check back to validate?

@michael.zoom this is getting sent as a lowercase boolean value ultimately, the code snippet is written in python/django and ultimately gets sent as proper json. Could there be another issue?

Hey @okzoomer,

Please try using the update meeting endpoint and setting the "registrants_confirmation_email" to false.

Thanks,
Tommy

Hi @tommy, this is still not working for me.

After creating a meeting with the correct settings (and setting both booleans to false), the values are as I want them to be (false), but on the meeting page it’s still shown that emails are activated and emails are sent if I register a participant. Using the update endpoint afterwards does not change anything! The values are set as I want them to, but emails are still always sent after registering participants.

I’d appreciate help since I have to disable all emails to registrants!

Hi @ki-trainer,

Can you double check your Account Level settings? Are your account level settings overriding the API request possibly?

To check, go to Account Management > Webinar Settings:
zoom.us/account/webinar/setting

Let me know if this might be the case.

Thanks!
Will