Requiring Registration Not Working

When I create a meeting and set option_registration to ‘Y’, it still doesn’t require nor allow registration. So in that case, when I try to submit a registration for a user, it gives me an error of: “This meeting has not registration required.” 

Registration for Webinars is working fine, but not Meetings. 

I’m assuming I’m not setting some parameter correctly but in reading through I’m unsure what that could be. 


Create Meeting


api_key: XXXXX
api_secret: ******
approval_type: 0
data_type: XML
duration: 60
host_id: b8vOIyDxSvy9zPD6BuJKmA
option_registration: Y
registration_type: 1
start_time: 2017-07-01T12:00:00Z
timezone: America/New_York
topic: jul 1
type: 2


<?xml version=“1.0” encoding=“UTF-8”?>
<topic>jul 1</topic>

Register User: 


api_key: XXXXX
api_secret: ******
data_type: XML
first_name: Sue
last_name: Hawkins
id: 459251713


<?xml version=“1.0” encoding=“UTF-8”?>
<message>This meeting has not registration required.</message>

option_registration is a boolean, pass “true” and see if that works.

Ah, that did it. Thanks. 

Hey Guys,

V2 Api is how this feature works. The option_registration parameter is missing.

Hey @gamebooker,

Yes, for requiring registration, pass in 0 or 1 for the approval_type in the settings object when creating a meeting.


@tommy My overall goal is simple: create a persistent meeting (basically runs forever) where the only people that can join are registrants that have been manually approved (via the API) So far, this seems impossible. Do you know of a way to achieve the goal I’ve stated?

I have a pro account and am attempting to emulate the desired behavior by creating a type 8 meeting that recurs daily with duration 24 hours and with approval_type: 1 because type 3 meeting does not seem to support approval_type 1 (it simply comes back as approval_type:2. (I’ve tried setting registration_type:2 but the value of registration_type seems to be ignored when creating a meeting via the REST API (registration_type does not even appear in the response).

Hey @dtzoom,

Can you share your request body and url so I can debug?

Have you tried using an Instant Meeting with a password or whitelisted domains instead of scheduling a meeting forever?


@tommy I am also running into the same issue:

I am trying to use the API to add registrants to a meeting that required registrants, but while testing I noticed that once a registrant has received the Zoom meeting link they could share that link with people who have not registered and those non-registered users could still join the meeting. Is this supposed to be the case? I thought that when a meeting was “registration required” it forced a user to join the meeting with the email that they registered with to prevent people from sharing private meeting links.

Hey @okzoomer,

Yes, the unique url sent to registrants should be treated as a password and not be shared.


While you cannot prevent someone from sharing the unique URL, there is a meeting option that allows only one device/connection from each unique URL. You can find the option (only in meetings requiring registration) under Registration Options --> “Allow attendees to join from multiple devices”.

FWIW, I do not see the multiple device option as part of the Create Meeting options, nor is it returned as part of the Get Meeting API response.

Note … If allow multiple devices is not set (i.e. 1 device per unique URL), if the authorized user joins first they will grab the single slot, however, if they arrive after someone else has used the uniqueURL they will be prevent from joining. We find it important to be clear in follow-up and confirmation emails that the URL is unique and should not be shared.


Hey @OregonDean,

Thanks for your comment! Others will find this helpful! :slight_smile:


I followed what you mentioned. Still I am able to join with the same URL using my mobile app but with different email ID.

I tried to set registrant status as “deny” after the user joins the meeting thinking that the URL will be invalid and no user will be able to join again with the same URL. But even that dint work.

@tommy @OregonDean would be a great help if you could suggest me any solution on this.

Hey @naveen,

What do you mean different email ID?

Can you please provide steps to reproduce the issue?


Hi @tommy

By different email ID I mean different users. Example:- I register as user01 and got the unique Join URL and joined the meeting. I deny user01’s registration. Now I pass this join URL to user02. Still, the user02 is able to join the meeting.

My second concern:- “Allow attendees to join from multiple devices” field is not available in Create meeting API. It is only available in Create Webinar API.

Hey @naveen,

So you are saying after approving user1’s registration, and then denying it, the unique join_url still works?

We are working on making the “Allow attendees to join from multiple devices” field available for the Create Meeting API. Stay updated here: