Scheduling a meeting with password does no does not work for all users

We are using the Zoom API to schedule meetings that have unique IDs and are password protected. However, for some reason this does not work for some users on our account.
This is an example of the meetings parameters that we are sending in the POST body to /users/{userId}/meetings:

{
  default_password: false
  duration: 15
  password: "8e7h9ohxfq"
  settings: {
    use_pmi: false
  }
  start_time: "2022-10-06T19:00:00Z"
  topic: "Scheduled Custom Meeting"
}

Then in the response we are expecting to find these fields:
id
encrypted_password
start_time
duration

However, the encrypted_password that we would use in our mobile app for joining the meeting is completely missing, as are any other password fields and the join_url doesn’t have a password in it either.

So what could be going on here, why is this working in some cases and not in others? And what can we do to fix it and get it working for everyone? I have tried setting my user profile’s meeting settings to match someone’s who this is not working for but I am still unable to replicate this issue on my account.

Hi @mikko1
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
What you are seeing is that when you call the API to create a meeting and you pass the request body that you have shared with us, it works with some users and not with others.
Is that correct? If so, could you please provide the response body for both cases here so I can look into this?
Best,
Elisa

We actually figured out the issue. The issue was that the “Meeting Passcode” Meeting security setting was disabled and locked at the group level. And because the setting was locked for the group, we could not add a password for the group member meetings even programmatically through the API. Removing the lock (but leaving the setting disabled by default) solved the issue.

Hi @Mikko
Happy to hear that you were able to resolve this!
Feel free to reach out to us anytime :slight_smile: