Zoom doesn’t require password to join the meeting


#1

I’d like to be able to schedule meetings with password to join the meeting.
I’m calling POST https://api.zoom.us/v2/users/{userId}/meetings to create a meeting, I’m including “password”: “333” , in my Request, I see the same password in the Response but when I click on the start_url (I’m the host) or when someone else in my team joins the meeting with the join_url, Zoom doesn’t require password to join the meeting.

I also tried restricting access that only signed-in users can join meetings, by adding “enforce_login”: True but that didn’t work either. Attendees could join with the join_url without being signed-in in Zoom.

Can someone advise please. Thanks!

Request:

{
“topic”: “my incident”,
“recurrence”: {
    “monthly_week”: -1,
    “end_date_time”: “yyyy-MM-dd’T’HH:mm:ss”,
    “monthly_day”: 0,
    “repeat_interval”: 0,
    “monthly_week_day”: 1,
    “type”: 1,
    “end_times”: 0,
    “weekly_days”: 1
    },
“agenda”: “”,
“settings”: {
    “host_video”: true,
    “watermark”: false,
    “approval_type”: 2,
    “mute_upon_entry”: false,
    “use_pmi”: false,
    “in_meeting”: false,
    “participant_video”: true,
    “auto_recording”: “none”,
    “cn_meeting”: false,
     “enforce_login”: true ,
    “join_before_host”: false,
    “audio”: “both”,
    “registration_type”: 1
    },
“duration”: 0,
“timezone”: “America/New_York”,
“start_time”: “yyyy-MM-dd’T’HH:mm:ss”,
"password": “333”,
“type”: 1
}

Response:

{
“h323_password”: “074823”,
“uuid”: “7AWXcXqkSKKb8rUg9/8rAw==”,
“settings”: {
    “cn_meeting”: false,
    “host_video”: true,
    “enforce_login_domains”: “”,
    “watermark”: false,
    “approval_type”: 2,
    “mute_upon_entry”: false,
    “use_pmi”: false,
     “enforce_login”: true ,
    “in_meeting”: false,
    “participant_video”: true,
    “join_before_host”: false,
    “alternative_hosts”: “”,
    “audio”: “both”,
    “auto_recording”: “none”
    },
“created_at”: “2018-08-22T18:08:50Z”,
“start_url”: “url”
“topic”: “my incident”,
“pstn_password”: “074823”,
“timezone”: “America/New_York”,
“duration”: 0,
“host_id”: “xxxxxx”,
“join_url”: “url”,
"password": “333” ,
“type”: 1,
“id”: xxx
}


#2

Hi Tamara, 

Your request looks fine. Can you email your full request and response including account ID, start/join url to developersupport@zoom.us so that we can investigate further?

Thanks