Screenshare is not working when went to background in iPAD

In ipad if teacher start broadcast and go to background, the screenshare video is getting struck for student.
Same scenario working fine in iphone device.

Background modes are enabled as mentioned in the documentation.
i tried to debug the issue in the SampleHandler “processSampleBuffer” method is getting called even in background but video is not going to the student side.
Can u help me to troubleshoot this issue further ?

SDK version:

=Not working device

  • Device: iPAD Air 2
  • OS: iOS 13.6
    =Working device
  • Device: iPhone 8
  • OS: iOS 14.4.1

Hey @lokeshkumar,

Thanks for using the dev forum!

Did you add the appDelegate method calls in your appDelegate like MobileRTC.shared.appWillTerminate?


Hi thanks for response
yes, added all the methods in appDelegate, working as expected in iphone but the problem is with the ipad.
Earlier we only have support for iPhone and now we added support for ipad and this issue emerged.
We are struck on this for making the release, Need help with this issue at the earliest.

Will RequiresFullscreen flag has any side effects ?

More observations:-

  1. Replay kit is working fine, since we are getting callback processSampleBuffer even in the background.
  2. In our POC app UIRequiresFullscreen flag true screenshare working fine, if we make it false its not working.
  3. UIRequiresFullscreen flag case we are not able to reproduce in our original app.
  4. Checked in one more iPAD Air 2 iOS=14.7, there also issue is coming.

Thank you.

Hey @lokeshkumar,

Using the same code for iPhone works but not iPad?


yes, not a single line change

Hey @lokeshkumar,

Can you reproduce the issue one more time and then obtain the SDK logs and send them to me at Please include a link to this post and mention my name in the email.


Sent the logs.


Hey Lokeshkumar,

Thanks! Will follow up with you there.


Still waiting for your replay in the mail for past 2 weeks.

Hey @lokeshkumar,

We do not have any updates yet, will let you know when we do.
Stay tuned.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.