SDKERR_MODULE_LOAD_FAILED - Not with the demo project

Hi ,

When I’m using the meeting SDK from within the demo project , Everything is working just fine.

My problem is that - I did a C# dll which is using the SDK and when I try to use it from IIS site(That’s the place I need to) , I’m getting SDKERR_MODULE_LOAD_FAILED (Even tough my IIS is able to run 32 bit applications), I’m also using the SDK key and SDK secret.

Any thoughts ?


Keep getting the error : AccessViolaition : Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Hi @eladw
Are you getting this error with the sample app?
If so, Could you share with me the sample app you are using so I can debug this issue further?

Hi Elisa ,

Thanks for the quick response.
When you say sample app if you mean the demo provided by you , so that’s fine when I run the project within the visual studio and even with out the visual studio as a normal process via cmd .

The problem is when I try to use this MeetingSDK through C# dll in IIS within AWS server
I keep getting this access violation error about the memory, Another thing I’ve tried is to run the process independently also in the AWS server and it’s worked fine so I guess the problem is within the IIS .

@elisa.zoom In case you didn’t see my response

Also when I try to run the C++ SDK from another new console application in C# I get

Hi @eladw
I am really sorry I just saw your response.
Let me look into this and I will come back to you with an update.

I am also sharing some posts that have seen similar error:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.