sharedBufferArray is true, but isSupportMultipleVideos is false

Hey Zoom Video SDK team,

I’m currently trying to use the renderVideo for self on the canvas and followed the detailed guide here: Web SDK Gallery View and Virtual Background

I signed up for the Chrome Origin Trials and added the token as meta to my header, and then added some console logging.

console.log(hasSharedBufferArray); correctly returns true, but then console.log(isSupportMultipleVideos); returns false… which gives me the You must pass a <video> element to start video error I’m trying to avoid.

How can sharedBufferArray be properly returning true, but the isSupportMultipleVideos API still return false?

To add a bit of complexity, my co-worker receives “true” when logging out isSupportMultipleVideos. So the error seems to be isolated to me, even though we’re using the exact same code (same branch). How can that be?

Appreciate the help.

Video SDK: 1.4.0. | OS: Mac Monterey, Version 12.5.1 (21G83) | Browser: Chrome, Version 104.0.5112.101 (Official Build) (arm64) | Codebase: React

If it’s helpful, I isolated this issue a bit further. Here’s what I found through some trial and error:

  1. I go into my Chrome Settings and into “Privacy and Settings > Site Settings > Camera” and remove the camera grant to localhost

  2. Then if I join a session and try to renderVideo it will ask for me to opt in my camera

and voila it works…

But… as soon as I refresh the browser (command + r) or otherwise reload the page, it stops working again until I repeat steps 1 + 2 above and re-opt-in the camera again.

I can’t quite get my head around what is taking place here… :upside_down_face:

Hey @parker

Thanks for your feedback.

Did you set a customized User-Agent or use Chrome to simulate a mobile device to access the web page?
If so, then since the Video SDK Web cannot support multiple videos in the same canvas on the mobile platform so far, the stream.isSupportMultipleVideo will return false.

Hope this can give you some clues to figure out the issue.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.