Signature invalid in Meeting SDK app type in NextJs

good news - the error is found :slight_smile:

Yes i will update here after creating it and if it works afterwards :slight_smile:

Update: I created SDK app and replaced its sdk key and secret to frontend and backend where i am generating signature. Unfortunately i am still getting invalid signature. Tried both CDN and React integration. Here is the new signature that was generated:


Also for testing i created a new zoom account and created new sdk app on it and used that credentials on CDN, still invalid signature. Strange

Hey @varcityzoom1 ,

Can you try using this sample app to generate the signature?

Make sure to pass in your Meeting SDK app type Client ID and Client Secret:

If that still does not work, please submit a devsupport ticket and ask the support team to check if the Meeting SDK is enabled for your account.


I used the sample app to generate following singature:

on decoding it has the following payload:
“sdkKey”: “lAzXXLSJQyKbYI1xZwqQOw”,
“mn”: “82295245018”,
“role”: 0,
“iat”: 1681189069,
“exp”: 1681196269,
“appKey”: “lAzXXLSJQyKbYI1xZwqQOw”,
“tokenExp”: 1681196269

and my sdk app client id is " lAzXXLSJQyKbYI1xZwqQOw" so it looks fine. Still I am getting

  1. errorCode: 3712
  2. errorMessage: “Signature is invalid.”
  3. method: “join”
  4. result: “Invalid signature.”
  5. status: false

So, not sure why it is even when i am doing all steps correctly

One more additional info, i already had a sdk app type created before feb, but its being depricated so i have created new one and tested using new app’s credentials

Same issue with CDN

is you meeting app active?

in my working (free) account with a “new” Meeting SDK is looks

you don’t use “localhost” ? I did’t know that file protocoll is working - I have never tested it

UPDATE: just testet - file-protocoll work also for me

Update: it work after retrying 4-5 times in cdn

perhaps you have a problem with the local time on your computer - if it’s some seconds wrong, such errors can happen

1 Like

It seems you were right, after auto syncing the time my CDN works in first attempt. Thank you. Now i will test it on my application

Ok its working now. Issue was the problem with the local time on my computer. After auto syncing the the system time it works correctly. Thanks @j.schoenemeyer for help. I will mark this as solution

since you’re already testing - can you check your original o-auth app works now with the corrected time

1 Like

Yes all my implementations are working


Glad to hear you were able to resolve the behavior you were seeing. For future reference, here is a guide on Troubleshooting Meeting SDK signature validation

Glad to hear you got it sorted @j.schoenemeyer !

We do recommend generating the signature on the server side, in UTC / GMT to avoid timezone / time sync issues, and also to keep your Client Secret, Secret.


1 Like

By trying out the simple CDN example, which only takes about 5 minutes, you can easily verify whether your Meeting SDK application is functioning properly or not, and this example can be tested on localhost without requiring any additional server configuration.

1 Like

Original issue was resolved but my leave button is not working due to some reason