The /report/webinars/{webinarId}/participants API doesn't see any webinars

Using this template helps us debug your issues more effectively :slight_smile:

I need to retrieve a participants report of a webinar

As a result i continuously getting message
{ "code": 3001, "message": "Meeting does not exist: {redacted}." }
I have tried to use UUID (one without slash in it) and got the same error

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?

How To Reproduce (If applicable)
To get this i have accomplished next steps:

  1. Got the JWT token from the account
  2. Executed request users/{redacted}/webinars with my user ID
  3. Executed request report/webinars/{redacted}/participants with one of the webinars ID listed in response of the previous request

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Hi @dev-zoom-api ,

  • How long ago was the webinar?
  • If it’s in the past and there was only 1 participant, you’ll need to use the ?type=pastOne query parameter. If there was more than 1, you will need to use the type=past query parameter.

Let me know if this helps!

  1. webinar startTime is “start_time”: “2021-09-30T14:00:34Z”
  2. it didn’t help
    webinar info is
            "uuid": "redacted",
            "host_id": "redacted",
            "topic": "redacted",
            "type": 5,
            "start_time": "2021-09-30T14:00:34Z",
            "duration": 60,
            "timezone": "Europe/London",
            "agenda": "nkJIYmGKROGSdgBFbatGwOIJRajaYFVWIoWueIccUQUtIJuBNyxbkeZxJkhGitwCvVSXMfhUdeJynEpHmBzGjroLwkxvaXYzSrkxksmkxhInzdMzBttsdOXPUYNhClUWwnbrYbxJSGeBGAmVDpCQQaUtmWncynNTelcsKdblWiBjctiUtOTzQrQooHgtsYgDvNDprPVAafUFGxuXLJwskscHDDRJKbnZiLcWJDHkRoKvNLcSHrmWqsOMWX",
            "created_at": "2021-09-30T11:00:39Z",
            "join_url": ""

Hey @dev-zoom-api ,

I can see record of the webinar in our system. Can you please private message me your full request and response bodies to each endpoint please?

Thank you,

I have no idea how to private message you via this UI and i can’t find your email

my request (GET){redacted}/participants?type=past
+ authorisation header

my response

    "code": 3001,
    "message": "Meeting does not exist: 88655138081."

I have found a reason.
The problem, as i think, is that i can’t build a report for webinars of other users.
The id 1l7dcQPvSh62E-Lvi_KS_A is an identifier of another user.
My authorisation gives me possibility to see all its webinars but i can’t see one by identifier to build a report

Ahh I see @dev-zoom-api – you would have to make sure your assigned role for your account allows the scope access for the particular endpoint.

sorry for late answer.

it has all required permissions.

The question is what criteria webinar should follow to be available for report generation?
Because i have found some webinars that can be used for report generation without any obstacles

Hey @dev-zoom-api,

If you reach out via our Developer Support Center with the specific webinars that you’re having issues with we can investigate them from there.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.