Trouble while starting the meeting in the latest version

Hi Team,
I am finding trouble while starting the meeting from android SDK. It was working totally fine before until I upgraded to latest version which was released on July 1st 2020 (v5.0.24433.0616). As i could see after upgrading to the latest version of SDK, the zoomToken param is missing in the StartMeetingParamsWithoutLogin, the data which we used to pass while starting the meeting is mentioned in the below screenshot,

The value is returned by meetingService.startMeetingWithParams(context, params,opts) is 99 even after passing the userType node.

Kindly see through the issue and let me know what else is missing while passing to start the meeting or do I have to do anything apart from that.

Please find the logfile here

Which version?

Hi @abhishekt,

Thanks for the post. There are some changes in SDK 5.0 as mentioned in and one of them is the userToken is being removed.

Please refer to the implementation here:


@carson.zoom even without passing that , i have tried passing the same values which is being mentioned there. Still i am getting the same return value as 99. Kindly evaluate this

Hi @abhishekt,

Based on the code snippet you are presenting here, please try the following:

  1. Remove params.zoomToken
  2. Change Constants.USER_TYPE_API_USER to MeetingService.USER_TYPE_API_USER

I have just tried this feature in our demo app and it is working as expected. Please have a try.

Hi @carson.zoom , I did the same as you said and replaced the Constants.USER_TYPE_API_USER to MeetingService.USER_TYPE_API_USER , still I am getting the return value as 99. The value of params.userType is setting as 0 when i assign to MeetingService.USER_TYPE_API_USER

Please check the below implementation

This is the returned value when debugged

@carson.zoom any update on the above ?

I am experimenting the same issue (error 99)… Obviously reverting back to the previous version of the sdk (with the zoomToken) the start meeting command works fine.

The ZAK and others parameters look correct.

The problem is present also using the Android sample application.

@criva as it is mentioned by @carson.zoom , he says it would probably work as per the params which has to be sent. But it is nowhere working. @carson.zoom Kindly give me an update regarding this

Hi @abhishekt,

Thanks for the follow up. I have forwarded this to the engineering team and the team is investigating this. Will get back to you shortly.


Hi @abhishekt,

Thanks for the details and info. We are able to identify an issue with the case you were mentioning and we have provided a hotfix for this. Please have a try with the latest version:



Thanks @carson.zoom for the quick action and seems like the issue is been fixed and I could able to start the meeting. Kindly go through my another issue reported while joining a meeting. Seems like you have have posted that you are going to provide an update for that.

Hi @abhishekt,

Thanks! The engineering team is still investigating that issue and I will provide further assistance in that post.