Turn Off My Video dont work

When i join meeting, i set isVideoOff and isAudioOff with true in JoinParam4NormalUser struct, but when i am in the meeting, my video still works. It makes me confused.

On the other hand, in the sdk_demo_v2 project, isVideoOff and isAudioOff work.

Besides, i find remaks showing that “In addition, this flag is affected by meeting attributes.” So, what makes isVideoOff and isAudioOff with true values dont work?


Hi 19bobo,

Thanks for the post. Are you using any sort of account level(on the web portal) or app level setting such as using EnableForceAutoStartMyVideoWhenJoinMeeting(https://zoom.github.io/zoom-sdk-windows/class_i_join_meeting_behavior_configuration.html#a91528d18d5d7e0d2ebe3bfead17860cc)?

As you mentioned, the isVideoOff and isAudioOff is working in our demo app if you do not have any other configuration that forces the video to be on.

Hope this helps. Thanks!

I have done some settings before join meeting. I’ll reset to find out which
one stops mute video.

Thanks for the reply. Hope you have fixed this issue. Let us know if any other questions. Happy Zooming!

I find the following code works for me:

    		auto pVideoSettingContext = m_pSettingService->GetVideoSettings();
		if (pVideoSettingContext != nullptr&& joinParam.userType == ZOOMSDK::SDK_UT_NORMALUSER)
			joinParam.param.normaluserJoin.isVideoOff = false;

		auto pAudioSettingContext = m_pSettingService->GetAudioSettings();
		if (pAudioSettingContext != nullptr&& joinParam.userType == ZOOMSDK::SDK_UT_NORMALUSER)
			joinParam.param.normaluserJoin.isAudioOff = false;

Thank you!

Hi 19bobo,

Thanks for sharing the solution. Yes, calling those app-level settings will ensure the audio and video works as expected.