Video always muted when joinning metting

Description
I have upgraded the SDK to v4.4.55130.0712. But when I joined the meeting, the video camera not opened automatically. I have to tap the “Start Video” button to enable it. This case not occurred on the pervious version.

Also, I have call the method setMuteVideoWhenJoinMeeting with false, but it not worked.

I have try the demo app from your Github repo, but the same problem has occurred.

Which version?
v4.4.55130.0712

Hi dapeng,

Thanks for the post. If the camera permission is granted, then the video camera should be opened by default. Could you please check your account configuration on zoom.us web portal to see if the video is disable by default.

Regarding the setMuteVideoWhenJoinMeeting interface, thanks for pointing that out. We will fix it in the next release.

Thanks!

Hi Carson,

I never found the configuration about the ‘the video is disable by default’ on the website.
When I installed the Demo SDK, I found the configuration about it on ‘Meeting Setting’ page, but when I set the switch to false, the camera capture still not opened by default.

So maybe you can reproduce this issue by the demo app on your iOS Github repo.

Thanks.

Hi dapeng,

Thanks for the reply. I will work with the engineers regarding this and get back to you.

Thanks!

Hi we also face the same issue when upgrading to sdk version v4.4.55130.0712. We have checked the user has already set to video on when joined the meeting.

Thanks

Hi Chi-gun,

Thanks for the reply. By default, the video is on. I have downloaded the demo app that is available in our Github: https://github.com/zoom/zoom-sdk-ios; I tried to join a meeting or start a meeting, the default video is on. Could you provide the steps to reproduce this issue?

Thanks!

Please check the video about this case. You can find the camera is muted.

Hi dapeng,

Thank you very much for the video. It looks like the case is: When starting a meeting using ZAK(non-login), video is off by default. I will work with the engineers on this and get back to you.

Thanks!

Thank you. We hope to get your feedback as soon as possible.

Hi dapeng,

We have identified this issue and we will fix it in the next release. We are expecting to have a release for this very soon.

Thanks!

Hi, we have same problem here.
Please let me know when you release next version.

Hey @junya100,

You can subscribe to our release log here to be notified.

Thanks,
Tommy

1 Like

Hi,
We upgraded the sdk to v4.4.55130.0712 (Android sdk) and video/audio are off by default.
The user must enable it manually by pressing the video/audio icon.
I Tried to assign JoinMeetingOptions with:

opts.no_audio = false;
opts.no_video = false;

and it didn’t work.
I initiate the JoinMeetingParams without user id and password:

JoinMeetingParams params = new JoinMeetingParams();
params.displayName = DISPLAY_NAME;
params.meetingNo = meetingId;
meetingService.joinMeetingWithParams(cordova.getActivity().getApplicationContext(), params, opts);

If it’s a bug, is there any workaround until the next release?
Thanks!

Hi Izhar,

Thanks for using Zoom SDK. Yes, this is a known issue and we will fix it in the next release. Right now, you may ask the host to use this interface:https://zoom.github.io/zoom-sdk-ios/category_mobile_r_t_c_meeting_service_07_video_08.html#aa4d28c13634f025d6371ea2597163251 to ask the participant to turn on the video.

We are going to have a release coming up. Please follow our Github repo for any updates:https://github.com/zoom/zoom-sdk-ios

Thanks!

Hi Carson,
Please aware that our problem occurs with Android SDK and not iOS (we didn’t upgrade the iOS sdk yet).
The links you mentioned are pointing to zoom-sdk-ios and not to zoom-sdk-android.
Is it a known issue in Android SDK also?

Hi izhar,

Thanks for the reply. Pardon the incorrect info provided. It is a known issue in both Android and iOS SDK.

There is a setting called enableForceAutoStartMyVideoWhenJoinMeeting(https://zoom.github.io/zoom-sdk-android/us/zoom/sdk/MeetingSettingsHelper.html#enableForceAutoStartMyVideoWhenJoinMeeting-boolean-), unfortunately, this setting cannot bypass this issue at the moment.

You may use the interface askAttendeeStartVideo to ask the user to start the video after the meeting started: https://zoom.github.io/zoom-sdk-android/us/zoom/sdk/InMeetingVideoController.html#askAttendeeStartVideo-long-

Please follow our Github repo for the upcoming release: https://github.com/zoom/zoom-sdk-android

Thanks!