TypeError: m.AK.connectSocket is not a function, i have the black screen when i try connect to the meet zoom

I have the next problem with two versions zoom sdk 2.17.0 and 2.18.0

m.AK.connectSocket is not a function
TypeError: m.AK.connectSocket is not a function
at tn (http://localhost:3000/static/js/bundle.js:43449:157)

at i..i..onmessage (http://localhost:3000/static/js/bundle.js:183212:26)

Please someone help me, i need the solution urgently

Hi @palejovr
Thanks for reaching out
Can you please try and replicate this with our sample app?

Hi Elisa,

I only have I have skdkey I do not have client id and client secret.

In the sample use client id and client secret.

Hi @palejovr
if you are working with a meeting sdk app, you should have client id and client secret

Hi, Elisa I have a sdk key, and i use this key in the react code y try again the connect with the zoom with the new version 2.18.2 but i get the same error.

In my zoom room I have that they are connected to the meeting but in the react client the indicated error appears.

My app is old, and this worked correctly in previous versions.

Please I need to help.

Thanks Alejandro, can you please confirm what version of the Meeting sdk you are using? as well as what react version you have?
Our latest version of meeting sdk 2.18 does not work with react 18, so you would have to downgrade your react to 16

The indicated change was applied but the error persists

can you take a look at this reply

I apply the same considerations but I have the same error.

This is the code I am using based on the react example:

import React from ‘react’;

import ‘./App.css’;
import { ZoomMtg } from ‘@zoomus/websdk’;

ZoomMtg.setZoomJSLib(‘https://source.zoom.us/2.18.2/lib’, ‘/av’);

// loads language files, also passes any error messages to the ui

function App() {

var authEndpoint = ‘https://demo-zoom1.cedia.edu.ec
var sdkKey = ‘KjmJzOcons8dqRWEaS5nLvxZbGvco1sSjkTy’
var meetingNumber = ‘81711557583’
var passWord = ‘VQ0z0y’
var role = 0
var userName = ‘React’
var userEmail = ‘’
var registrantToken = ‘palejovr@gmail.com’
var zakToken = ‘’
var leaveUrl = ‘http://localhost:3000

function getSignature(e) {

fetch(authEndpoint, {
  method: 'POST',
  headers: { 'Content-Type': 'application/json' },
  body: JSON.stringify({
    meetingNumber: meetingNumber,
    role: role
}).then(res => res.json())
.then(response => {
}).catch(error => {


function startMeeting(signature) {
document.getElementById(‘zmmtg-root’).style.display = ‘block’

  leaveUrl: leaveUrl,
  success: (success) => {

      signature: signature,
      sdkKey: sdkKey,
      meetingNumber: meetingNumber,
      passWord: passWord,
      userName: userName,
      userEmail: userEmail,
      tk: registrantToken,
      zak: zakToken,
      success: (success) => {
      error: (error) => {

  error: (error) => {


return (

Zoom Meeting SDK Sample React

    <button onClick={getSignature}>Join Meeting</button>


export default App;

are you running the sample app?

I try but i have the indicated error

I also am facing the same issue and not able to resolve it. I installed the Angular sample app, but the issue is still there. Please provide some useful information to resolve it ASAP. Thanks.

Exactly, the problem persist, @elisa.zoom we need your help to resolve this problem please.

I am experiencing the same issue. Although it works in the sample app, when I attempt the same approach, the problem persists.

I present the same error when I upgrade my app to version 2.18.2.