TypeError: m.AK.connectSocket is not a function

I’m using meeting SDK 2.18.0, with Next.js
and I got this issue when join the meeting

error: “TypeError: m.AK.connectSocket is not a function”

1 Like

I am getting the same problem. Even while using the git repo of the zoom.
Some suggestion will be great.

I have the same problem, please someone help us.

Same, maybe related to the React18 incompatibility with Client version.
Kind of don’t understand why it’s not already fixed…

1 Like

Hi all!
We are looking into this issue, there is incompatibility with React 18 and the latest version of the meeting webSDK. Please try downgrading to React 16

i am getting same issue in meetingsdk-angular-sample also. can anyone help here?

@ganeshparajuli199 @elisa.zoom @palejovr @webda2l @shishir.gaire11

guys I solve it, u can use version (2.16.0):

const { ZoomMtg } = await import('@zoomus/websdk')
    ZoomMtg.setZoomJSLib('https://source.zoom.us/2.16.0/lib', '/av')

even with react and react-dom 18

@mohammad.qebalah @elisa.zoom

I did exactly what you said:

const { ZoomMtg } = await import('@zoomus/websdk')
    ZoomMtg.setZoomJSLib('https://source.zoom.us/2.16.0/lib', '/av')

and left my package.json as follows:

"dependencies": {
    "@testing-library/jest-dom": "^6.1.4",
    "@testing-library/react": "^14.0.0",
    "@testing-library/user-event": "^14.5.1",
    "@zoomus/websdk": "^2.16.0",
    "react": "^18.2.0",
    "react-dev-utils": "^12.0.1",
    "react-dom": "^18.2.0",
    "react-scripts": "^5.0.1",
    "web-vitals": "^3.5.0"

but when I connect to the call I get the following error on the web:

Uncaught runtime errors:

JsMediaSDK_Instance is not defined
ReferenceError: JsMediaSDK_Instance is not defined
    at Nt (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:188098:15)
    at d (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:68025:34)
    at b (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:68085:209)
    at Z (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:192163:2275)
    at combination (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:321890:29)
    at dispatch (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:321652:22)
    at http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:321363:16
    at Object.zmg_setMeetingInfo (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:321904:12)
    at a.value (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:63662:21)
    at C (http://localhost:3000/static/js/vendors-node_modules_zoomus_websdk_index_js.chunk.js:198516:178)

Hi, I also tried, but I had the same error.

One more thing guys. I’m using React.js (CRA) not Next.js
here’s the package-json:

    "@zoomus/websdk": "2.16.0",
    "graphql": "^16.8.1",
    "react": "^18.2.0",
    "react-dom": "^18.2.0",

the thing is, I created a react app just for the meeting and deploy it on a sub domain just for it like (meetings.xxx.com), so in future I can use it with any other app.

After downgrading to React 16, same problem. At least, represent your thoughts on git repo which was given to us by zoom.
You are saying React is not compatible with the latest zoom, then in the repo, why the user has used the React version 18.

hello @mohammad.qebalah can you test on angular sample from your side. It will be great help.

hey @siddiqbarbhuiya
we are working on a fix to that repo too and an overal fix to this issue.
In the meantime the workaround that I provided works with the sample app

I try with angular but i have the same problem.

With version 16 it gives the following error:
JsMediaSDK_Instance is not defined

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.