Unable to get refresh token


#1

I have created an app in the new marketplace, an Account-Level app. I have ALL scopes checked. When I authenticate (or re-authenticate), I get an access token successfully and am able to use it until it expires. However, when I try to refresh it using my refresh token, I get the following error:

Invalid request : Unable to narrow the scope of the client authentication to requested scope.

It was working fine up until recently. I am unable to find any answers about this error message anywhere else.


#2

Hi @andrew,

Thanks for letting us know about the error, I’ll report this to our marketplace engineers and follow with you as soon as I hear back from them.

Can you also share with us the app ID and the email associated to the account as well?

Thanks


#3

The Client ID is YAfJLZSuSvuK7rkLTIUrKA and the email is andrew@wearegamechangers.com


#4

Hi @andrew,

Would you be able to provide the specific time range and endpoint when you tried to make the call? Also, if your stuck while we investigate, a quick workaround would be to reauthorize the client and authorize the scopes as well.

Thanks


#5

We’ve received the error upon every endpoint call that we tried to make, but I’ve JUST now made a couple of calls to /v2/users/me and I’m getting the same error message.

I’m using a JWT that doesn’t expire until year’s end as a work around right now, but would prefer the protection of oAuth.


#6

@Michael_Purnell Any more information on this?