URL Schemes problem for Host to Start meeting

Hi,
just trying to make work link on my project to launch Zoom client using url Schemes as explained in the docs.

Links for atendees to join works,like this:
‘zoommtg://zoom.us/join?confno=xxxxx320464&pwd=xxxxx75&zc=0&uname=’+this.user.nombre;

But cannot make work link for host to start meeting like this:
‘zoommtg://zoom.us/start?confno=xxxxx320464&pwd=xxxxx75&zc=0&stype=100&uid=xxxxx-TLTPOctOEf-xxxxx&token=eJ6sypS9ia-xxxxxxxxxxxxxx.BgUsM0RqZHIzSzQ4eEF2ckNEeTBqV0dLL2FsRDRVaFNpS2hVeGQ3eUVRYWFlcz1AODc4OTFiMmJkYjM0ZjJlZDU3YWZhZmU2ZDUyMDFhMjRmNWIwNmQ3MjA2MTZhYTY4MDc2NDNiOWZjYmZmZGIwYwAgTVJxMThVWko4Z3RNelNqQko4UDJKUzk3RjV1UU81N0sAAA&uname=’+this.user.nombre

where uid is the id of the host user retrieved via API https://api.zoom.us/v2/users/xxxx@xxxx.com -this is the host’s mail … -
and token is just that user’s auth token retrieved via API https://api.zoom.us/v2/users/xxxxx-TLTPOctOEf-Nxhbw/token

It launches Zoom client but:
1.- still asks for the password, even when it is specified in the params list
2.- finally keeps waiting, claiming it is waiting for host to start the meeting…

Can you help me?
am i missing something?

Thanks in advance!
Regards

Hey @desarrollos.nit,

Can you private message me your full url scheme so I can debug?

In the meantime, you can use the start_url returned from the Create and Get Meeting endpoints…

Thanks,
Tommy

Hi @tommy ,
I am having the similar issue and this is the full url scheme. How can I private message you the full url?

is this issue is resolved, i am getting same issue, any updates on this ?

@gitesh.purbiya22,
Based on my testing, it is not. I can confirm all parameters are correctly supplied except password is not working. Here is my method to test

  1. start meeting with password. zoom client not signed in. prompt for sign in
  2. start meeting with password. zoom client signed in. start meeting successfully.
    These two test proves at least other parameters are supplied correctly.
  3. join meeting with password. zoom client not signed in. able to join without prompt for sign in
  4. join meeting with password. zoom client signed in. able to join without prompt for sign in

Furthermore, everything is working fine if using start_url returned from the response.
Same behavior for both Linux and Windows.

1 Like

you are right, with start_url, which we are getting from response, it is working fine and can start meeting without password prompt. But there is a issue with URL scheme,

1 Like

Hey @gitesh.purbiya22, @tingung.hu,

Currently to start a meeting with the URL scheme, you must be signed into your Zoom Client.

If you do not want to be signed in when starting a meeting, like you both said, use the start_url. :slight_smile:

Thanks,
Tommy

Hi @tommy,
“You must be singed into your Zoom Client” - Is it a bug or expected behavior?

If it is an expected behavior, why we have “password” in zoommtg scheme url to start the meeting? eg: Windows/macOS Client: zoommtg://zoom.us/start?confno=123456789&pwd=xxxx

If it is a bug, how should I keep track of the bug status?

Update: Even meeting is created without password, zoommgt is not able to start the meeting. It will behave like join meeting, waiting host to start meeting.

Thanks.

I agree with @tingung.hu and as @gitesh.purbiya22 ask it is not resolved.
@tommy helped me with this some days ago and finally suggested me to use start_url.
the point for me was that i did not want any king of redirection such us when you use start_url and that’s why tried to use url schemes.
Did the little trick of using the start_url on an iframe created on the fly, which works perfectly on desktop but not always on mobile devices…

Regards

Right. I can change the application to use start_url if it is expected behavior. If it is a bug, I will temporarily switch to start_url and use zoommtg scheme url once bug is fixed.
In browser application, we managed to use iframe to trigger https scheme url and it only prompt to open (no new tab).
However, it doesn’t works in native app (web application running in embedded chrome). Haven’t figure out how to resolve it yet. Waiting the confirmation as bug or expected behavior. If bug, I think I will wait for the fix instead trying to fix in native app.

Hey @tingung.hu, @desarrollos.nit,

It is expected behavior currently. For the most consistent experience, please use the start_url.

Thanks,
Tommy

Is a bug expected behavior? Why isn’t that fixed?
What is the use of URL schema if the password does not work?

Desperately looking for this working zoommtg start url to work without asking password, token method not working, still asking for password.

Hope this gets solved at the earliest.

Hey @abhinay, @danvsantos,

Please use the start_url instead while we look into this.

Thanks,
Tommy

Any update here, this is one of the core requirement defines our business dependency on Zoom usage in future

Hey @abhinay,

No updates yet. It is in the engineering queue to be investigated. (CS-2057)

Thanks for your patience,
Tommy