Video is not rendering when more than 1 participant starts his video in Firefox in SDK v1.2.5

Video is not rendering (black) when more than 1 participant starts his video in Firefox browser in latest SDK version and In Firefox browser console we can see below error:

reason: "subscribe video counts greater than maximum size (1)" type: "INVALID_OPERATION"
(Its getting thrown from stream.renderVideo )

Same case is happening If one user in Chrome (or any other browser) & other in Firefox and both user tries to start their videos then also Firefox is throwing this error.

Browser Console Error
reason: "subscribe video counts greater than maximum size (1)" type: "INVALID_OPERATION"

Which Web Video SDK version?
Web Video SDK 1.2.5

Device:

  • Device: Macbook Pro
  • OS: macOS 11
  • Browser: Firefox
  • Browser Version: 99.0.1 (64-bit)

Additional context
This issue is happening in the 1.2.5 version of SDK only.

Hey @shoaib

Thanks for your feedback.

We have found this issue and we will release a hotfix version (1.2.7) soon.

Thanks
Vic

2 Likes

Hey @shoaib ,

This has been fixed in version 1.2.7:

Thanks,
Tommy

1 Like

I am getting this error while using Zoom Web Video SDK version 1.3.0

Browser Console Error
reason: "subscribe video counts greater than maximum size (1)" type: "INVALID_OPERATION"

Which Web Video SDK version?
Web Video SDK 1.3.0

Device:

  • Device AMD Ryzen 5 2600 Six-Core Processor (desktop)
  • OS: Windows
  • Browser: Google Chrome
  • Browser Version: 102.0.5005.63 (Official Build) (64-bit)

Hey @kvr

Thanks for your feedback.

Did you enable the Cross-Origin Isolated on your site? If the SharedArrayBuffer is unavailable on the site, only one video can be rendered on the same canvas unless enabled the enforceMultipleVideos option in the init method.

Thanks
Vic

I had this problem when clearing the canvas before calling stopRender video, then I didn’t remove the canvas but just set display:none

Anyway, I used one canvas per user and all canvas was paused when I had 5-6 participants. For now, I just use only one canvas, rendering by X, Y and it works fine.

If isSupportMultipleVideos returns false, please add these lines to nginx header

Cross-Origin-Opener-Policy: same-origin
Cross-Origin-Embedder-Policy: require-corp

or use this link to generate a token and add this line to your index

	<meta http-equiv="origin-trial" content="token">

That was my case, hope it helps someone

Ver: 1.2.7
Env: VueJS