Web SDK Audio Not Working

Description
We have embedded the Web SDK (latest version 1.9) in to the website and everything is working fine, except the audio is not received by users joining on the website. We have integrated the stream from Zoom to pull into a designated area of the page to fit with the design, and as a result hid the majority of the Zoom components that overlay the stream so it doesn’t distract the user, but for one reason or another, the audio just doesn’t receive on any device or browser.

Error
Audio not coming through to viewers.

Which version?
1.9.0

Screenshots

Device (please complete the following information):
All browsers and devices

Additional context
When the “Join Audio” is not hidden and the user clicks this, this does allow the sound to come through but is there anyway of this happening as soon as the user joins?
We are using the Zoom stream to run live webinars that users will join at different times, so it’s important that as soon as the stream loads, the audio is received.

Thanks in advance.

Hey @robert.dyas,

Thank you for reaching out to the Zoom Developer Forum. Just to clarify, you’re hiding the Join Audio button and are looking for a way to automatically join the user audio, is that correct?

If so, please see the following historical forum post:

I hope that helps! Let me know if you have any questions.

Thanks,
Max

Yeah that’s correct.

When the timer (set via web database) is hit via a check function, it loads the Zoom stream in for all users that are currently on that page.

As some users will join this webinar after it’s started, once they reach the webpage the webinar will already be in progress.

Due to this the audio will need to be present as soon as the stream is visible.

I will take a look at that thread now thank you.

I followed the guide as per that topic but unfortunately the Zoom audio isn’t automatically joining.

As a stop gap I have enabled the “Join” pop up and audio control on the embed, but ideally would like to get this joining users automatically to the audio.

I couldn’t find the option in the docs for where to initiate the users audio when they join via the SDK - would you be able to assist in letting me know the option to add?

Code for the ZoomMtd.join is below:

ZoomMtg.join(
	{
		meetingNumber: meetConfig.meetingNumber,
		userName: meetConfig.userName,
		signature: response,
		apiKey: meetConfig.apiKey,
		userEmail: meetConfig.userEmail,
		passWord: meetConfig.passWord,
		success: function(res){
			console.log('join meeting success');
		},
		error: function(res) {
			console.log(res);
		}
	}

);

Thanks in advance

Hey @robert.dyas ,

There is no way to automatically have the participant join with audio. They have to give consent by pressing the “Join Audio” button, which will then prompt the browser to access their audio / mic.

Does that make sense? Let me know if the issue is actually the audio itself.

Thanks,
Tommy

Thanks @tommy.

That’s what we have done. A future request would be good to be able to specify that users join automatically with audio if a valid audio device is detected, just for situations like this where live webinars / conferences will be run.

Hey @robert.dyas,

Thank you for the update. The ability to have users automatically join with their microphone is a useful feature. For the most part, we are restricted by security features of browsers that require user interaction in order to access these devices.

If you would like this feature to be considered for a future release, I recommend posting in the #feature-requests category.

Thanks,
Max