Web SDK not working on React.js without explanation

I’m trying to implement Web SDK on React.js project and I can’t get it to work.

I’m using this example on git - https://github.com/erickTrettel/zoom-sdk-react.

I tried with versions 1.7.9 and 1.7.10.
I have a premium account with payment details.

I tried all the following option:

// ZoomMtg.setZoomJSLib(‘https://source.zoom.us/1.7.9/lib’, ‘/av’);
// ZoomMtg.setZoomJSLib(‘https://dmogdx0jrul3u.cloudfront.net/1.4.2/lib’, ‘/av’);
// ZoomMtg.setZoomJSLib(‘https://dmogdx0jrul3u.cloudfront.net/1.7.10/lib’, ‘/av’);
// ZoomMtg.setZoomJSLib(’…/…/node_modules/@zoomus/websdk/dist/lib’, ‘/av’);
// ZoomMtg.setZoomJSLib(‘https://source.zoom.us/1.7.10/lib’, ‘/av’);

After all of this, I click on the button JOIN and nothing happens, not a success message and not an error message.

If I click twice I see the animation ‘Joining Meeting’ with an error message:
{method: “join”, status: false, result: “”, errorMessage: “You have reached the API limit for this call.”, errorCode: 3633}

In the first line - import { ZoomMtg } from ‘@zoomus/websdk’; - I see the following message:

Could not find a declaration file for module ‘@zoomus/websdk’. ‘/Users/avichaydahan/Desktop/test/zoom-sdk-react-master/node_modules/@zoomus/websdk/index.js’ implicitly has an ‘any’ type.
Try npm install @types/zoomus__websdk if it exists or add a new declaration (.d.ts) file containing declare module '@zoomus/websdk';ts(7016)

I know how to implement and install npm packages off curse… I see it on the package.json and in the node_modules.

I tried to run the program on Chrome, Safari, and incognito mode, all with the same result.

Really need your help guys.

Thank u so much

I finally did it. Thanks

Hey @avichay.official,

Happy to hear you got it working! Let us know if you have any other questions! :slight_smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.