Zoom Web SDK is not working after upgrading to version 2.18.0

@tommy I am using React version 18.1.0 in my application to integrate with zoom web SDK and once I upgraded my zoom package after I faced a sudden issue with 2.17 to 2.18 using @zoomus/websdk, the meeting started not to work at all and kept getting errors on the console with React not defined, and React-dom not defined every time I try to join. however, It was working properly before that

here’s a sample from my packages.json file with installed versions
@zoomus/websdk”: “^2.18.0”,
“react”: “^18.1.0”,
“react-dom”: “^18.1.0”,

1 Like

with Zoom Web SDK Client View you have to use react 16.14.0

Hello @j.schoenemeyer , first of all, thank you for your reply

I already checked this notice a couple of days ago, however, I just can’t get it, whenever I need to make things work by integrating Zoom into my application I have to downgrade my application dependency version with considering all the conflicts that will appear of other packages that I already have, for matching the exact react version that zoom support Instead of upgrading zoom dependency with the latest version that was already installed before?!

I have integrated zoom in my application for more that a year now it was working properly even without notifying with the changes but it was okay usually I just have to upgrade


to latest version and update the react-select, bootstrap, etc. dependencies and it was working fine after that

Also, take into consideration I’ve checked the reactjs sample provided by the documentation in zoom repository the last commit provided by @tommy it was holding the upgrade for react, react-dom and some other dependencies to 18.2.0 how is that sample working there?

I even tried to downgrade the zoom into 16. version I received the old error of missing media thing in console

I hope we can collaborate for having a fast solution for this issue

I am getting the same errors using v2.18.0 and react 16.14.0.

Have no idea what is going on there, but, I think it’s all about whether defining react explicitly using import React from 'react'; also the same for Dom package, or it might be about upgrading npm and react dependency in module and taking actions about incompatibility issues that will appear for some installed packages from zoom’s side

Facing the exact same error :slightly_frowning_face:, have you got any solution?

Hello @Jason11 ,

Don’t know about your case about using Zoom, however, I’ve made a workaround till we get a new upgrade with the solution for this issue.

I’ve replaced the join meeting method temporarily with a redirection to a generated meeting URL from BE so we can place the meeting in the Zoom application itself and avoid the current error with SDK

Hopefully, this works for you too

1 Like