WEBSDK - sudden problem with signature


Description
I have a simple page that has Zoom Web SDK built into it. Created last Saturday and it worked perfectly, tested again yesterday and it worked perfectly. Tried today and it doesn’t work: the message “Signature is invalid” always comes out. I tried updating sdkSecret, changing the version (from 2.8 to 2.9), trying to generate the signature with php, trying to download the demo by changing only sdkKey and sdkSecret but the result is always the same. What can it depend on?

Browser Console Error
{method: ‘join’, status: false, result: ‘Invalid signature.’, errorMessage: ‘La firma non è valida.’, errorCode: 3712}

Which Web Meeting SDK version?
2.9.0

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to LikeEvent
  2. See error

Troubleshooting Routes

  • change sdkSecret
  • update sdk version
  • try with other language
  • try with sample web sdk app

Device (please complete the following information):

  • Device: [Macbook Air]
  • OS: [macOS 11.3]
  • Browser: [Chrome]
  • Browser Version [e.g. 88.0.4324.150 (Official Build) (x86_64)]

@ale.g ,

Thank you for posting in Zoom Developer Forum – I am happy to help you! As a start, can you share if you are still seeing the same issue? If so, could you share the snippet of code that is being used to handle the signature generation? This information will help us diagnose what may be happening.

Please let me know if you have any questions about this!