Webtoken not acceptable for api calls

I opned my account a few months ago to experiment.
Now i need to develop and my webtokens are unacceptable for api calls.
i get 401 messages. i tried testing it out on your website with the same result.
is this because i didnt use the accoutn for a while?
my app shows as “Activated” but “Intend to publish: No Account Level” is showing.

Error: Request failed with status code 401
Which App Type (OAuth / Chatbot / JWT / Webhook)?
Knowing the endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:
Additional context
Add any other context about the problem here.

Hey @nadavtalalmagor,

Can you ensure that the expiration timestamp for your token hasn’t expired? This would be the most likely cause. The JWTokens contain an exp field that I would recommend double checking. You can also generate these via your JWT app in the marketplace, and set the expiration date there:

Let me know if this helps!


Hi and thanjs for ykur reply.
I regenerated a new jwt token from my accout and tried using it and got the 401 response.
Is there a time limit for using zoomapi?
Do i need a “pro account” or something?
Thank you very much

Hey @nadavtalalmagor,

What endpoint are you trying to hit? Can you share your full request and the response here? I’ll be happy to take a closer look.


Hi. The endpont is https://api.zoom.us/v2/users
The error is “Request failed with status code 401”
This is the token
Thanks for your help

const zoomApiBaseUrl = ‘https://api.zoom.us/v2/’;
const axios = require(‘axios’)

const getUsers = async (req, res) => {
console.log(‘getting zoom user’)
const url = zoomApiBaseUrl + ‘users’
var options = {

qs: {
status: ‘active’ // -> uri + ‘?status=active’
auth: {
//Provide your token here
‘bearer’: zoomApi.zoomMainJwtToken
headers: {
‘User-Agent’: ‘Zoom-Jwt-Request’,
‘content-type’: ‘application/json’
json: true // Automatically parses the JSON string in the response
// const response = await axios.get(url)
method: ‘get’,
url: url,
config: options,

Hey @nadavtalalmagor,

Thanks for providing that! In testing this endpoint just now, I was able to successfully retrieve users with the token you shared.

Can you try submitting this request in Postman and let me know if you experience the same issue? Here are the details you should provide:


Thank you very much.
Your tutorials are showing how to to use nodejs with request library which is depricaded so it will be great if it show with axios ot other builtin libraries.
Do you have the exact syntax for axios request? i want to make sure everything is right there.
Tjank you very much for your help

Hey @nadavtalalmagor,

I’m glad that was helpful! While I don’t have the exact syntax for Axios, you might consider using the Code generator/button in Postman to generate a code snippet for NodeJs-Axios.

I hope this helps!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.