When i run the demo App threw an error during load: Library not loaded: @rpath/ZoomSDK.framework/Versions/A/ZoomSDK Reason: image not found

when I download the project and then followed the steps:

  1. Run sh build_nodeaddon_mac.sh to rebuild the node file.
  2. Run sh run_demo_mac.sh to run the zoom demo.

But I get this error, can help me find why it throws an error?

zoom-sdk-electron git:(master) ✗ sh run_demo_mac.sh
file exist

test1@1.0.0 start /Users/xxx/Desktop/demos/zoom-sdk-electron/demo
electron .

App threw an error during load
Error: dlopen(/Users/xxx/Desktop/demos/zoom-sdk-electron/sdk/mac/zoomsdk.node, 1): Library not loaded: @rpath/ZoomSDK.framework/Versions/A/ZoomSDK
Referenced from: /Users/xxx/Desktop/demos/zoom-sdk-electron/sdk/mac/zoomsdk.node
Reason: image not found
at process.func [as dlopen] (electron/js2c/asar.js:155:31)
at Object.Module._extensions…node (internal/modules/cjs/loader.js:850:18)
at Object.func [as .node] (electron/js2c/asar.js:155:31)
at Module.load (internal/modules/cjs/loader.js:677:32)
at tryModuleLoad (internal/modules/cjs/loader.js:609:12)
at Function.Module._load (internal/modules/cjs/loader.js:601:3)
at Module.require (internal/modules/cjs/loader.js:715:19)
at require (internal/modules/cjs/helpers.js:14:16)
at init (/Users/dyk/Desktop/demos/zoom-sdk-electron/lib/zoom_sdk.js:32:17)
at Object.getInstance (/Users/xxx/Desktop/demos/zoom-sdk-electron/lib/zoom_sdk.js:186:20)

Node version 10.15.1
Electron version 5.0.2
Node-gyp 6.1.0

Hi dongyuekai,

Thanks for using Zoom SDK. Based on the error message, it seems like the corresponding Zoom SDK files have not been found and the path is not right. Please double-check your path.

Hope this helps .Thanks!

Thank you for your answer! now i run npm run packager-mac , i can get a package, but i cant run it by ‘‘electron .’’ . maybe the path is not right , i Haven’t found.

Hi dongyuekai,

Thanks for the reply. I have just tried the steps from our Github page and I was able to run the demo without any issues.

Please make sure you are doing in the following order:

  1. Download the demo app, and cd to the file
  2. Follow the instruction here https://github.com/zoom/zoom-sdk-electron#development-environment-configuration-for-mac to install node, Electron, etc.
  3. Then follow this instruction https://github.com/zoom/zoom-sdk-electron#for-mac-platform to build the demo app and run it.

If you are using macOS Catalina, please don’t forget to grant the SDK demo app the proper permission to run and access the libraries.

Hope this helps. Thanks!

I did it exactly the same way again, but it was the same problem.

Hi dongyuekai,

That’s strange. Are you using the latest version of Electron SDK from https://github.com/zoom/zoom-sdk-electron? Did you modify anything(such as move the files in the package around) after the download? And did you get any errors while installing the dependencies and run the sh build_modeaddon_mac.sh?

Hope this helps. Thanks!

yeah i am using the latest version SDK and i did not modify anything, when i run the sh build_modeaddon_mac.sh i got lots of warnings, such as

Hi dongyuekai,

Thanks for the reply. The warning won’t affect the usage of the SDK demo, I am seeing these warnings as well. So I think this might not be the reason why it is not working.

When running the sh build_nodeaddon_mac.sh, the script is copying the libraries to the proper places for the demo to work, something or some errors might exist while running the shell script.

Just notice that the node version you have(10.15.11) is different from the one mentioned in the instruction, which could be the reason why it is not working. Our demo requires node 12.0.0 and electron 5.0.2 to run.

Hope this helps. Thanks!

I reinstalled node 12.0.0 globally and the problem was resolved, thanks!

Glad to hear that it is working. Happy Zooming!