When using external mic, zoom switches from recording internal audio to recording from the mic

When using a USB mic, Zoom will start recording from the mic. This results in worse sound as I cannot mute my mic, without losing all the audio.

When I am recording using the internal mic, Zoom records internally allowing me to mute my mic for a cleaner sound.

Is there a way I can fix this (I do not see anything in the options).