While trying to fetch access token , getting invalid authorization code with invalid grant type error


While trying to fetch the access token with the auth code, it is failing with invalid authorization code with invalid grant type.

Provided the code details via developersupport@zoom.us.

Could you kindly help regarding this issue

Hi @jomy.paul2 ,

Have you heard back from support yet? Are you able to successfully make API requests otherwise?


Hi Gianni, didnt hear from support yet.

I also tried making API request, i get the same error

Hi @jomy.paul2 ,

Try following this guide please to get the correct OAuth token to make requests:


Thanks Gianni for helping with the collection information. But I was not able to locate authentication apis from the collection.

Similarly in zoom phone apis, could not locate authenication apis.

Could you kindly help regarding the same and provide a collection that has authentication apis.

Hi @jomy,

What do you mean by authentication APIs? You can do OAuth authorization for each API endpoint by clicking the “authorization” tab and following the steps outlined in the guide.

Does that clarify what you were looking for?


Hi Gianni,

I was talking about APIs to fetch access, ZAK and refresh tokens. I am not finding those APIs in the collection to test.


Hi Gianni, when i tried the steps - going to an API, and sending request to get tokens by providing my cliend id and secret. it created the tokens from postman.
But via code with android sdk, it is failing. the error says invalid authorization code , invalid_grant

I had this issue and was able to debug. I found it easier to start w/ a cURL and debug from there.
My issue was that I was not using production clientID / client secret for the authorization credential


curl -X POST 
-H "Authorization: Basic [base64(clientID:clientSecret)]" 
-H "Content-Type: application/x-www-form-urlencoded" 

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.