X-zm-signature & x-zm-request-timestamp are missed in deauthorization webhook


When uninstalling application I receive deauthorization webhook. I want to verify webhook event request as described in doc: Zoom Developer Docs. But x-zm-signature & x-zm-request-timestamp headers are missed, only authorization header is presented.

Is there anything I need to configure inside my application to start receiving x-zm-signature & x-zm-request-timestamp headers or I’m doing smth wrong?


Hi @kosar.dmitry , I cannot reproduce this. Can you please create a support ticketso we can investigate further?

Include in the ticket:

  • application credentials
  • link to app credentials page
  • event verification token
  • deauth url
  • screen shots of deauth response
  • a link to this post

Thank you!

I am facing the same issue so I raised the support ticket
Please respond ASAP

Hi @ajaiswal2 ,

Our support team will get to you as soon as possible. They appreciate your patience.



I submitted a support ticket with the same issue, but was told to address this issue on devforum.
Tried today again, but still no headers. I have ClientId and other headers though. Is there any update for this issue?


Hi @Olegs ,

Please review the troubleshooting webhooks post here: "We Are Not Receiving Webhooks As Expected" -- Here's What to Do!

Then, can you please send them the link to this post (where we are conversing) within your support ticket?