Zoom API - Unable to retrieve access token



Details on your question, workflow or the problem you’re trying to solve.

I am trying to retrieve SMS information from one of our organization bot account but the initial step to retrieve token using basic auth is not returning any data back though upon making API call the status is returning 200 ok but no token in the return response

How To Reproduce
Steps to reproduce the behavior:
1. Request URL / Headers (without credentials or sensitive info like emails, uuid, etc.) / Body
2. Authentication method or app type
OAuth App has been configured in marketplace
Client key and secret has been taken from the application initial page
Encoded the ClientKey:ClientSecret and provided basic base64encoded value as authorization
3. Any errors
No content/ token in the response with 200 OK

Hi @question

Did you create an Oauth2 app or what kind of app have you created?

Let us know!


Thank you for looking into this request.

We tried both OAuth and Server to Server Auth apps.

For both the apps, with endpoint provided before containing “v2” there is no return of token with 200 status but if we make call by removing “v2” from the endpoint, that gets us access token but that with that token we are unable to call any API.

For example, with the token we have got from


we attempted to call below endpoint:


But resulted in “400 Bad Request”

“code”: 200,
“message”: “Invalid api key or secret.”

So we are running into couple of Q’s:

  1. Are we to make auth call without “v2” in the endpoint?
  2. But for making other API calls we have to include “v2”?
  3. In that case, why does the token returned without v2 in the creds endpoint is not working with other API call even though it has scope?

Thank you for the help,

Thank you for the help.

We have found a workaround with this by making API call to the account credentials directly in the call.

But can you please provide help on whether we can delete an Session and SMS/MessageId using REST API?

Is DELETE method allowed?

Tried endpoint: https://api.zoom.us/v2/messages?message_id= which again returns 200 but the message is not being deleted.

Can you please provide the correct endpoint for deleting session and message if any?

Thank you

Hi @question
Unfortunately, we do not have a Delete method for SMS or sessions.
Feel free to create a feature request here