Zoom Crashes after being accepted in a meeting - DrawerLayout

After being accepted in a Metting, Zoom suddenly crashes. The root cause is described to be DrawerLayout

Which version?

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Open a meeting
  2. Wait to be accepted
  3. App crashes

Video of the crash/steps Zoom Crash - DrawerLayout

Smartphone (please complete the following information):

  • Device: Huawei P Smart
  • OS: Android 9 / EMUI 9.1.0
  • NOTE happens on any device

Additional context
I’ve double checked and have included all the dependencies from the guide. All are included
This is a link to pastio with the full traceback -> link

Hi @alexandru.hadar, thanks for using the devforum.

Sorry to hear you’re running into this crash. I have tried reproducing this with my device, but with no success. Can you provide a snippet showing how you are joining the meeting as well as the full logs from the device? Please ensure that you have enabled logging by setting ZoomSDKInitParams.enableLog to true before capture the device logs.

Also, is this crash reproducible 100% of the time?


Hey! Thanks for responding.

It occurs 100% time.

This is a further error I’ve been able to identify another error regarding the Keystore, which I think might be the cause: KeyStore Exception. It happens as soon as we open the initialize the SDK.

This is the way we initialize the Zoom SDK: VideoChatUtil. When we want to start a meeting, we simply call startVideoChat

Hi @alexandru.hadar, thanks for the additional info.

I’ve tried a number of times to reproduce this, even by changing the values of my key/secret to be invalid and was unable to see the crash you are describing. I would suspect that this issue was device-specific, but your original post explicitly states that any device can reproduce this.

It also appears that this is happening at some point after you have initialized the SDK, since it is occurring when you are already in the waiting room of a meeting.

Are you able to reproduce this crash in our sample app?


I will try to reproduce it.

Meanwhile, are there any special permissions and/or manifest flags I should be aware of?
This was initially working, but the crashes started to happen after we extended the app, adding new libraries.

Hi @alexandru.hadar,

The fact that this started happening after adding new dependencies could be indicative of an issue. Could you provide a snippet showing your dependencies block in your build.gradle file?


Sorry for the late reply.

I am able to run the sample. It works perfectly. This is my dependencies tree link (pass is deps)

Hi @alexandru.hadar,

The link you’ve provided is missing an address.

Also, since you are unable to reproduce in the sample app, would it be possible for you to send over your app to developersupport@zoom.us so that we may further investigate on our end?