Zoom Phone API (Roles)


GET /phone/roles

Unable to access this endpoint (server to server oath) but able to access others. Error in screenshot. When looking at the required Scope for this endpoint (View all users’ phone information > phone:read:admin) it is checked but it is grayed out. My assumption is this means it’s enabled by default but can’t find anything else to make this work.

403 - You do not have permission

Hi @joe.sweeney ,

This error is typically related to user role permission and access. What is the role of the user you’re using to generate the access token being passed to these endpoints? How is it scoped? Your account owner and admin should be able to access this info: https://support.zoom.us/hc/en-us/articles/115001078646-Using-role-management


Thank you Gianni! It was in fact related to the Role (Admin) of the User that had created the Oauth app. Once I enabled a few items in the Admin role it began to work for us. We are now running into the same issue with the /im/groups and /im/groups/{groupId}/members endpoints, both of which require the imgroup:read:admin scope. That scope is selected in the Oauth app and all options are checked in the Admin role within Zoom. If it makes the most sense, I can spin this up as a separate thread.

Hi @joe.sweeney ,

I’m glad the initial issue is resolved :slight_smile:

For IM groups, Zoom implemented some changes last summer that could be impacting set up and access. Please comb through the changes identified in the following articles and use process of elimination for your account: