Zoom REST API failing with valid access tokens


#1

Hi, 

 

My Zoom API integration was working fine until this morning and now calls are failing with error “Invalid access token” code 124.   Nothing I’ve tried is working across several different OAuth projects.    Refreshing the token succeeds but using that token in API calls fails.

To try and isolate this issue I’ve tried the following:

  1. created a new user level API project (id is 2ArsxUnDQMqSmiwl_gVAHQ) and with scopes " user :read" and " user_profile"
  2. using Postman with the development credentials, I am able to successfully get an access_token with scopes " user:read user_profile"
  3. I then issue a GET request https://api.zoom.us/v2/users/me/ with a bearer tokens (Authorization: bearer xxxx) and this returns me an error “Invalid access token” code 124.

Did something change on the Zoom API?  AFAICT I’m calling things correctly…

Thanks,
Nigel.


#2

Hi Nigel, 

When calling the APIs are you using Zoom’s authorize url (https://zoom.us/oauth/authorize…) or client credentials (https://api.zoom.us/oauth/token?grant_type=client_credentials…). .%C2%A0)

Thanks


#3

Michael, you’re correct I was using the client credentials.   I switched to the authorize endpoint and it’s now working.   

Thanks,
Nigel.