Zoom SDK Initialization failure

I have given my SDK Key & SDK secret correctly, But every time it throws an error message as

onZoomSDKInitializeResult, errorCode=2, internalErrorCode=3023

I have a very similar issue on iOS. When trying to initialize the SDK, the app crashes because of a NIL URL somewhere. I have provided all the parameters needed for initialization:

Log output: *** -[NSBundle initWithURL:]: nil URL argument

Hi marimuthu.g,

Thanks for using Zoom SDK. The error code 3023 means the SDK key & secret are invalid. Are you getting this error from our demo app or from your own project?

In our demo app, the default parameter passed to the initParam is JWT token instead of SDK key & secret, please don’t forget to change that, otherwise, even if you storing the correct key & secret in Constant.java, the credential that is passed to initParam will be the invalid JWT token, which results in error 3023.

If that is not the case, could you provide the SDK version you are using, the steps to reproduce this with our demo app?

Thanks!

Hi ar3396,

Thanks for using Zoom SDK. What is the SDK version you are using? Are you facing this issue with our demo app or your own project? Could you provide the steps to reproduce this with our demo app?

Thanks!

Hi,

SDK Version Used: v4.6.15801.0403
Check with demo app.

In AuthConstants. File, I given the valid SDK key & Secret key

public final static String SDK_KEY = “9zSu**********erA”;
public final static String SDK_SECRET = “qI69**************smn2Z”;

For zoom sdk initialization
ZoomSDKInitParams initParams = new ZoomSDKInitParams();
initParams.appKey = AuthConstants.SDK_KEY;
initParams.appSecret = AuthConstants.SDK_SECRET;
initParams.enableLog = true;
initParams.logSize = 50;
initParams.domain=AuthConstants.WEB_DOMAIN;
initParams.videoRawDataMemoryMode = ZoomSDKRawDataMemoryMode.ZoomSDKRawDataMemoryModeStack;
mZoomSDK.initialize(context, this, initParams);

Then i run the demo application. Still the same error occur.

InitAuthSDKHelper: onZoomSDKInitializeResult, errorCode=2, internalErrorCode=3023

Kindly provide an solution.

Hi marimuthu.g,

Thanks for the reply and the info. Could you try to deactivate the SDK app on Marketplace and then re-activate it again and see if it helps?

Thanks!

Hi,

Tried but still the same issue is there…
Tried with regenerate a secret key also. But still throws an error

“InitAuthSDKHelper: onZoomSDKInitializeResult, errorCode=2, internalErrorCode=3023”

:

Hi marimuthu.g,

Thanks for the reply. Let me contact you shortly.

Thanks!

Hi, @marimuthu.g
Is your issues resolved?
I am also getting same error.

Hi ruchikasolanki1999,

Thanks for using Zoom SDK. Could you have a try to regenerate your SDK secret on Marketplace and see if that helps? If not, please let me know.

Thanks!

Hi @Carson_Chen

I am also facing the same issue and I tried regenerating the SDK secret on Market Place and also tried deactivating & reactivate it again. But still I am getting the 3023 error code.

Thanks

Hi santoshu,

Thanks for using Zoom SDK. Could you send the following information to developersupport@zoom.us:

  • Email address of your SDK account
  • Brief description of this issue

Once we receive this information, we will investigate and help you resolve this as soon as possible. Thanks!