Zoom SDK initialize not working in release mode in android

i have successfully build an app using Zoom SDK, which is running good in debug mode but once i release it then the problem comes…

Problem is in sdk.initialize this line giving me an error in release mode. i dont know why, i have already tried to log it but as we know in release mode its not logging where in debug mode it is. now i am really confused whats going on. please help me to find out problem.

Which version?
Zoom SDK version is 4.6

Additional context
i have correctly added SDK key and SDK Secret key infact its running in debug mode. i have one doubt as well because i can see sdk.Initialize seems deprecated , please let me know if thats thats true in 4.6 SKD version also please let me know the replacement of sdk.initialize

Hi abgroup.com.np,

Thanks for using Zoom SDK. What is the SDK version you are using? Could you follow the instructions here:https://marketplace.zoom.us/docs/sdk/native-sdks/android/mastering-zoom-sdk/sdk-initialization#2-log-feature to enable the SDK log feature and send us an SDK log so that we could further investigate the issue you are mentioning?


Hi Carson,
i have already tried, i think you didnt read clearly what i wrote. i have already mention skd version and i have already tried to log the error but its not loggin in release mode , log is working only in debug mode.

This is the problem… please let me what to do…


Hi abgroup.com.np,

Thanks for the reply. We have a few 4.6 versions(v4.6.15086.0209, v4.6.15801.0403, v4.6.21666.0429), which one are you using? Could you verify and refer to the implementation of our demo app for SDK initialization? (https://github.com/zoom/zoom-sdk-android/blob/master/mobilertc-android-studio/sample/src/main/java/us/zoom/sdksample/initsdk/InitAuthSDKHelper.java#L36) If your implementation is the same as the demo, is our demo has the same issue (working in debug mode and not working in release mode) on your machine? I have tried to reproduce this with our demo app but no luck.